Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Simple uploads don't work

Go to End

6 Posts   1824 Views


Community Member, 3 Posts

20 April 2012 at 1:31pm

Edited: 20/04/2012 1:32pm

I have recently installed Silverstripe and I do like it for a simple CMS and blog, but it seems to have numerous problems.
The primary one seems that you basically can't upload anything reliably.
I tried upload files and images and just get "Not a valid file!" errors.
If I use a FTP program then I have no drama except I have to constantly "Look for new files" and refresh and keep my fingers crossed.
I tried the "DisplayAnything" addon and that doesn't seem to do anything, but then again it appears you have to add 40 lines of code to some page somewhere to "implement" it? Lost me. Thats another story.
Is there any patch or update, access settings or something that will enable me to simply upload files and images via the Files and Images section. (Or an addon/extension that works)
It DOES sort of work using FTP clients but that basically defeats the purpose!
I have noticed numerous concerns on uploads but can't seem to find a answer!


Community Member, 189 Posts

20 April 2012 at 1:49pm

What kind of files are you trying to upload? are they large files? that could be causing issues as well.

see this thread for some more info on that.


Forum Moderator, 1899 Posts

20 April 2012 at 8:05pm

Edited: 20/04/2012 9:38pm

This also depends on the version of SS you are using...

2.4.5 -
2.4.7 -

(well for me anyway!)


Community Member, 3 Posts

21 April 2012 at 2:02pm

Trying to upload png, jpg and gifs for use within articles etc.
Also trying to upload pdf and other files used in association with the artical. pdf, zip etc

I run SS version 2.4.7 on a vps I own, running Centos 5 with 1GB mem etc.
PHP 5.3.8, with memory limit 64M, Post_max = 8M , upload max size = 2M
The files are generally less than a 100K.
Larger files I upload manually using FTP
On a rare occasion files will give the error, but then magically appear when I look for new files etc.
The problem with manually uploading graphics, is it doesn't seem to create the resampled images all the time.

I also find if I try setting up sb-folders then it doesn't seem to recognise the paths in many cases.
Again I generally have to manually create the folder as well as create it through the CMS with the same name. Sometimes I can use them, sometimes I will need to delete and try again.
I was hoping I could set up file system to mimic site map, to store images and files within their own groups, but it seems to want everything in the main assets folder or ONE subfolder, ie assets/downloads, assets/images etc. NOT assets/story1/images or assets/story1/downloads/files/ etc

Is there any info on what file access should be. because I seem to have to set everything to 777 which I am not real keen on, and it also seems like it might be an access problem.


Community Member, 3 Posts

25 April 2012 at 1:25pm

Just an update: I tried reinstalling SS on a Xamp on windows and it seemed to work fine. When I reinstalled fresh onto my Centos vps, it did exactly the same. Definately something to do with permissions but unfortunately couldn't find an answer.
I even changed permissions of everything to 777 so I assume its an iternal bug.
Thanks for the help, but we've had to change to an alternative for the main site. The upload / download is a primary requirement we needed, and although its possible using FTP it still seemed a little clunky.
SS works like a treat on xampp, just not my VPS.
Waiting eagerly for version 3 to come out and hopefully solve a few of the minor issues.
We'll keep trying an the other site and see what happens.


Community Member, 6 Posts

7 May 2012 at 1:56pm

Hi, I'm the author of the DisplayAnything module.

I'm interested in your issue as there is no extra code to implement - where is this extra 40 lines of code?
You can add a template for the public side of the site but that's up to you as we don't know how you are going to implement your gallery or file list. The example on the Github page should give some initial pointers.

If you have an issue implementing the module, please create an issue ticket so we can resolve anything outstanding as we head to a stable 1.0 release. Please include browser information and any error messages.

James, Codem

"I tried the "DisplayAnything" addon and that doesn't seem to do anything, but then again it appears you have to add 40 lines of code to some page somewhere to "implement" it? Lost me. Thats another story.