Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

SS3 multilingual


Go to End


11 Posts   2757 Views

Avatar
spierala

Community Member, 80 Posts

28 June 2012 at 1:21am

Edited: 25/07/2012 1:56am

Hello all,
I wonder if ss3 would be recommended for a multilingual site.

so far i can´t find much documentation about it.
any advice would be highly appreciated.

I think this is very important. Why there is not a little tutorial on that topic? I thought SS3 will really show off now with managing multilingual sites...

thx and kind regards,
Florian

Avatar
spierala

Community Member, 80 Posts

25 July 2012 at 2:02am

ahhh I´ll try to become lucky here:
https://github.com/silverstripe/silverstripe-translatable

Avatar
dc6jgk

Community Member, 3 Posts

25 July 2012 at 2:43am

If you manage to get that to work properly, please let me now.
I have played with that for almost a day now without getting it to produce a properly rendered translated page. Translated pages are accessible but the CMS never seems to apply the theme correctly, independent of which theme is selected.

(see http://www.silverstripe.org/all-other-modules/show/20463 )

Avatar
spierala

Community Member, 80 Posts

16 August 2012 at 1:17am

I just installed this:
http://www.silverstripe.org/translatable-module/

which is supposed to be a 1.0.0,
but it does not work at all (with SS 3.0.1)

If I select in the Pagetree a new Language and Press the Button "GO" then I get a white page with the text "The action 'LangForm' does not exist in class CMSPagesController".

In Edit Page View when I select the Tab Translations and select a language and press "CREATE" nothing happens...

Kind regards,
Florian

Avatar
danzzz

Community Member, 175 Posts

28 August 2012 at 5:53am

have the same issue ... I thougt this is a stable version 1.0.0, the download link promisse that
http://www.silverstripe.org/assets/modules/stable/silverstripe-translatable-1.0.0.tar.gz

or do we anything wrong??

Avatar
spierala

Community Member, 80 Posts

28 August 2012 at 6:01am

hey danzzz,
The problems seem to be fixed in the latest commits of cms and translatable on git:
https://github.com/silverstripe/

worked fine for me.
Regards,
Florian

Avatar
danzzz

Community Member, 175 Posts

28 August 2012 at 7:42am

thx spierala,

that dont worked for me ... I downloaded the latest "silverstripe-cms" files and the latest "silverstripe-translateable" ...
you thougt that, right?

Avatar
spierala

Community Member, 80 Posts

28 August 2012 at 7:43pm

hey danzzz,
what exactly does not work?
so did you get the latest files?
https://github.com/silverstripe/silverstripe-cms
https://github.com/silverstripe/silverstripe-translatable
just download the zips there.
greetz,
florian

Go to Top