Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

hard question about cron, sapphire cli functionality and permisisons

Go to End

3 Posts   1016 Views


Forum Moderator, 224 Posts

27 July 2012 at 11:15am

Edited: 27/07/2012 11:19am


I have written the following bash file (

cd /my-web-dir/
svn cleanup
svn up
php sapphire/cli-script.php dev/build

for some reason it runs fine if I run it like this:


however, when I run it as a cron job it ALSO runs, but all of a sudden it requires a username and password for the /dev/build/

I have NO idea at all on how to fix this. Any ideas?



Forum Moderator, 5523 Posts

28 July 2012 at 1:25pm

Is your cron job running as the same user as the one you're using to manually call the script.


Forum Moderator, 224 Posts

29 July 2012 at 7:23pm

Edited: 29/07/2012 7:24pm

to be honest, I don't really know... i will have a look at it... thank you!