Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Can't load the admin page to log into the CMS

Go to End

3 Posts   1364 Views


Community Member, 2 Posts

20 August 2012 at 2:56pm

I have been trying to solve this for hours. I have just installed SS, done the building a basic site tutorial, then installed a new theme and done nothing to it yet. When on the home page I click the link on my homepage that should take me through to the CMS (the urls is I get taken to this url http://**/Security/login?BackURL=%2Fadmin%2Fpages
which is fine. I have seen that before when I go to the login page. It's just that in firefox I am getting an error as follows:

XML Parsing Error: mismatched tag. Expected: </input>.
Location: http://**/Security/login?BackURL=%2Fadmin%2Fpages
Line Number 165, Column 3:</div>

in safari I get
this page contains the following errors:
error on line 167 at column 7: Opening and ending tag mismatch: input line 0 and div
below is a rendering of the page up to the first error.

and I can see the username and password fields but not the login button. Hitting entrer doesn't work.
Does anyone know what file the syntax error is occurring in? I have tried to work that out but can't seem to.
Thanks for any help!


Community Member, 18 Posts

28 August 2012 at 8:48pm


Not sure if you have solved this, but I am also getting the same issue.

It seems to be a bug and has been reported on the bug tracker, and is supposed to be fixed in 3.0.2 according to the milestone.

However for a fix:

If you look at the source of the web page when this issue appears, you will see that there are two <input fields that do not have a closing tag.

The problem is that the html page is being generated with a DOCTYPE saying it is an XML file. XML requires that all opening tags must have associated closing tags. In Firefox and Chrome etc. their XMLParser throws an error page when tags are not complete. IE tries to display the page, but then bombs out without erroring, which is why you do not see the Login button etc..

To quick fix the issue, until a proper solution is supplied, is to replace the DOCTYPE in the file in the themes/themename/templates/ directory with the one that the Simple template uses eg. DOCTYPE html


<!-- <?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" ""> -->
<!DOCTYPE html>

In the above I have commented out the first two lines so they can be added back when a real fix is provided.




Community Member, 2 Posts

30 August 2012 at 9:49am

Thanks for that tip. I eventually deleted the instance of silverstripe and reinstalled it. then I got the same problem. ZI worked back and realised that it was caused by the theme. I have since used one of the new ss themes (one of the finalists in the theme comp) and all has been well. So I concluded that old themes could cause problems in SS 3. Not sure if that is an accurate conclusion.
Thanks for your response