Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Can't list directories in Images -> Find in Folder

Go to End

5 Posts   924 Views


Community Member, 5 Posts

28 August 2012 at 2:21pm

I've successfully inserted images into pages using the standard image upload feature of Silverstripe, however when I try to browser existing images to re-add them to other content pages, the Find in Folder select fails silently.

What I'm doing:

-- I have an image in the system already; I can see it in my Uploads directory, there is a record for it in my File table, I can add it to a content page

-- I open another page to edit in the CMS, click the Image button in the RTE, select the "From the CMS" tab, i see the 1. Find in Folder (choose) input field.

-- I click that Select field, and see the Uploads directory name, I click the Uploads entry in order to list it

-- I get a flash of the "Loading" gif, the Network tab tells me that a request is fired to /admin/pages/edit/EditorToolbar/MediaForm/field/Files but the select field goes back to saying (choose)

There are no javascript errors in the Console, I have Silverstripe dev mode on in my config and there are no PHP errors

I have this issue on a site i've been working on, as well as a fresh install of Silverstripe. I have set my uploads directory to 777 permissions (although I can already save images to it; i don't think it's a permissions thing)

If i inspect the response of the XHR /admin/pages/edit/EditorToolbar/MediaForm/field/Files, it is the whole contents of the Insert Media pop up (eg it starts off:

<form id="Form_EditorToolbarMediaForm" action="admi[...]

Is this a bug with Silverstripe? Anything else I can do to debug it?


Community Member, 5 Posts

28 August 2012 at 2:30pm

It may be unrelated, but let me add that I get a 404 error when I click the Choose field for:


(note the double admin/ in the url)

I am using URL rewriting but it all appears set up totally fine; no other assets in the admin give 404 errors...

Even if i copy the bg_cms_main_content.png to that non-existent admin/admin directory the File browser doesn't work, so I dont think it's related...



Community Member, 107 Posts

28 August 2012 at 6:28pm

not sure if this will work, but try going to admin/assets/ then press " look for new files " or "sync files" for SS3 .. I had something similar a while back & i think this is how I got it fixed :)


Community Member, 5 Posts

28 August 2012 at 6:42pm

Thanks for the suggestion; i've tried Files -> Sync Files (which I assume is what you're talking about). I also tried using the task: /dev/tasks/FilesystemSyncTask

It reported that a few new images were added the first time, but neither changed the faulty behaviour.

Any ideas? :)


Community Member, 107 Posts

30 August 2012 at 12:36pm

I am out of ideas :(
Just make sure you have SS3.0.1 (the cms in SS3.0.0 is buggy ) & if you have admin/admin in the URL that means something wrong happened while installing . Never had this error but try a re-install ! Just remove the _config from mysite & re-install using the same database so all it does is update it ( make a backup just in case ).