Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Google Sitemap SS v3.0

Go to End

11 Posts   4628 Views


Community Member, 103 Posts

28 August 2012 at 8:29pm

Hey there,

I did try the module Google Sitemap, but it doesn't work on my installation. No error, but also no sitemap.

Has anyone any idea how to make it running? Do I have to configure something?

Thanks in advance.

- Mario -

Christopher Darling

Community Member, 6 Posts

30 August 2012 at 3:08am

Seems to work fine for me - although I've got the module via the github repository so may be worthwhile giving that a try?


Community Member, 3 Posts

4 May 2013 at 8:37am

Check permissions on the sitemap folder. In my case that was the problem. I assume you have solved the problem in the meantime, but just for the case someone has the same problem...


Community Member, 103 Posts

4 May 2013 at 11:08pm

Yes, solved in the meantime.

The module did work, but I didn't see the indexed and splited sitemap.

So... my fault :-)


Community Member, 8 Posts

13 May 2013 at 8:46pm

Hi, for me i dosent work, i always get an error
SS 3.0.5

Warning: Missing argument 2 for Object::add_extension(), called in /home/clever-fit/ on line 29 and defined in /home/clever-fit/ on line 453 Notice: Undefined variable: extension in /home/clever-fit/ on line 454 Fatal error: Object::add_extension() - Can't find extension class for "" in /home/clever-fit/ on line 460

Best regards bastiR


Forum Moderator, 5522 Posts

15 May 2013 at 8:08pm

Make sure you download the correct version for your version of SS. The composer.json describes your version requirements. for 3.0


Community Member, 7 Posts

15 July 2013 at 5:12am

Edited: 15/07/2013 5:14am

this is what my sitemap looks like:

<?xml version="1.0" encoding="UTF-8"?>
<sitemapindex xmlns="">

Silverstripe version 3.0.3


Forum Moderator, 5522 Posts

15 July 2013 at 6:32pm

This is normal susgeek. It's the index to other files (see, why do you have an error?

Go to Top