Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

SS 2.4.7 set_suffix_requirements(false);

Go to End

3 Posts   1020 Views


Community Member, 20 Posts

13 October 2012 at 12:08am

I've a problem with Silverstripe 2.4.7
Requirements::set_suffix_requirements(false); doesn't work. I set this in mysite/_config.php but I still get mtimesuffixes on my css files.

I want this disabled because of the serverside caching algorithm.
I deleted the silverstripe-cache folder, but that didn't help.

Maybe it's a Problem with some of my modules?

I've even changed Requirements.php line 773 from
return "{$prefix}{$fileOrUrl}{$mtimesuffix}{$suffix}";

return "{$prefix}{$fileOrUrl}"; //{$mtimesuffix}{$suffix}";

still got the suffix from somewhere else.

please Help.


Administrator, 690 Posts

15 October 2012 at 1:51pm

It sounds like the reason it's still appearing is because responses are being cached somewhere, or perhaps it's the serverside caching algorithim that you speak of?

If you put "?asdfasdf=23423423" onto the end of the URL for your HTML page, do they still appear? If not, it seems like there is an HTTP cache, either on your server, or it's just your browser cache.


Community Member, 20 Posts

15 October 2012 at 10:43pm

Thanks for response.
Your right, they do not appear if I put something like "?asdfasdf=23423423" to the end of the url.
But normally they appear in every browser. On the live server and on my devserver (ubuntu 12.04).
I all other silverstripe installitions on my dev-server Requirements::set_suffix_requirements(false); works correctly.