Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Run Silverstripe Forum in PostgreSQL

Go to End

8 Posts   1068 Views


Community Member, 6 Posts

4 April 2013 at 1:55am

I use SilverStripe 3.0.3, forum is the latest from Github, postgreSQL 9.1, php 5.4.7.

I have a problem to run the forum in PostgreSQL, what am I missing?

I downloaded the module and integrated it with dev / build. Everything work so far with no problems, even in the admin area, the Forum will be displayed. Only when I go to the home page and click on the Sitetree, that brings me to the forum there is the Server Error Page shown and not more. Neither in the console or elsewhere is an error thrown.

Do I need to change something somewhere eg: from MySQL to PostgreSQL in the forum? If i had to change something, where is this?
Can someone please help me?

Sorry for the bad english ;).

lg Kerry


Forum Moderator, 1391 Posts

4 April 2013 at 3:09am

Hi kerry,

Did you put the site in dev mode? That might shed some light on what the error might be...

In your mysite/_config.php




Community Member, 6 Posts

4 April 2013 at 4:15am

Yes I put the site in dev mode. But there is only one error but this error was there before I integrated the forum. But maybe you now what to do.

[User Deprecated] DataObjectDecorator is deprecated. DataObjectDecorator is deprecated. Use DataExtension instead. Called from ReflectionClass->newInstance.

Line 171 in C:\SilverStripe\framework\dev\Deprecation.php


162 $level = self::$notice_level;
163 if (!$level) $level = E_USER_DEPRECATED;
165 // Then raise the notice
166 if(substr($string,-1) != '.') $string .= ".";
168 $string .= " Called from " . self::get_called_method_from_trace($backtrace, 2) . '.';
170 if($caller) {
171 user_error($caller.' is deprecated.'.($string ? ' '.$string : ''), $level);
172 } else {
173 user_error($string, $level);
174 }
176 }
177 }

Thank you for the quick response.



Community Member, 6 Posts

4 April 2013 at 6:08am

Edited: 04/04/2013 6:09am

What I found out, is that the forum searches the css und the JS in the wrong domain/directory and it has the wrong port. The way to my path is this: localhost\Test\Silverstripe\themes\...

but the forum search in localhost:8081\Test\themes

where could I change this? or is something saved in the database because I changed the port a few weeks ago?
The next thing is that I'm not use the simlpe theme is that a problem?



Forum Moderator, 1391 Posts

4 April 2013 at 7:30am

Edited: 04/04/2013 7:34am

The error tells you that some code somewhere uses the DataObjectDecorator but in SS3.0 this class is no longer valid, in favor of the DataExtension class, so that code - whatever it is, is not really supported in SS3.0

The bit in the errormessage that tells you where the error originates is missing from your post, so I don't know what the offending code is.

The other problem might have something to do with the cache, because in SilverStripe paths are not stored in the database. Try a ?flush=1 or a ?flush=all and see if that helps...

EDIT - I can't really say if the theme you're using has any influence - but that's easy to test by temporarilyt enabling the default (simple) theme and see what happens...


Community Member, 6 Posts

4 April 2013 at 6:51pm

I tried the ?flush=1 and the ?flush=all but the path is still the same wrong one. I send you the output of the firebug (image). The red text in the image is the wrong path.

Is there anything else I could do?

Or how can i change the forum theme?

Maybe is there something to change, that the forum works in postgreSQL?
Because in the _config.php of the forum there are these two lines:

Object::add_static_var('Post', 'create_table_options', array('MySQLDatabase' => 'ENGINE=MyISAM'), true);
Object::add_static_var('ForumThread', 'create_table_options', array('MySQLDatabase' => 'ENGINE=MyISAM'), true);


Attached Files

Community Member, 6 Posts

4 April 2013 at 7:45pm

Now i have tried to start a new Homepage. I integreted the postgresql Modul and the Forum modul and a dev/build.
Now i get this when i click on the Link(Sitetree) to the Forum:

Has anyone an idea?

Attached Files

Forum Moderator, 5523 Posts

11 April 2013 at 8:11pm

The forum hasn't fully been upgraded to 3.0 so some errors are still present. I haven't used forum with postgres before so likely issues. Please raise any errors as issues (if not already on it) on (