Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

PARTIALLY FIXED - Unable to "insert media" "from the web" in CMS

Go to End

4 Posts   1416 Views


Community Member, 13 Posts

5 November 2013 at 11:50am

Edited: 15/11/2013 8:52am

When I attempt to insert a YouTube video from a URL found on YouTube I receive an "Internal Server Error" message. The same error occurs when attempting to insert a picture from a URL. I'm able to insert pictures from My Computer and from the CMS without any issues.

I tried using "dev" mode, but when I bring up the "insert media" window I receive an error from Silverstripe that says "Warning on line 418 of GD.php". The rest of the window fails to load and everyything remains white. When I review this file I see the line...

case 1: imagegif($this->gd, $filename); break;

This file is in its default state and no changes have been made to it. I read somewhere else to remove the _resampled directory from Uploads and then recreate with 777 permissions. I have tried this, but the GD.php error persists and I'm still unable to embed anything from the web.

I want to be able to embed from a URL.

By no means am I good with SilverStripe or Linux so take it easy on me! I have been able to correct permissions problems in other directories to get images to display properly, but am not sure what I'm doing wrong and am also not sure why there is an error with a default gd.php file.

Any and all help is appreciated. Thanks in advance.


Forum Moderator, 1391 Posts

8 November 2013 at 4:11am

I don't know what's going on, but the complete errormessage might give you a better clue. Unfortunately, on Ajax calls, you always end up with just get that little box and a fraction of the error...

If you have access to access/error logs you might find the errormessage there. I usually use Firefox with the Firebug extension. Using its netpanel you can select the url that is retreived in the Ajax call, check out the response and most times you'll see the entire message.

Lots of alternatives probably - but this at least almost always works for me :)


Community Member, 1 Post

12 November 2013 at 9:29pm

Thanks :)


Community Member, 13 Posts

15 November 2013 at 9:00am

THE PARTIAL FIX: php5-curl not installed. Found this from the logs.

I can now insert both pictures and video from the web. The issue was that php5-curl was not installed.

NEW PROBLEM: Video inserted from Web edited to be "on left, with text wrap" shows up on left with text wrap in CMS. When the page is displayed outside of CMS the text wrap is gone. The next paragraph is shown below the video. The border that is shown around the video in CMS is also gone.

The text wrap and border problem isn't present when inserting a picture from the web. This all works as it should.

I have tried different videos. I have also tried editing the HTML for the page so that the placement references to the video (that doesn't wrap properly) and the picture (that does wrap properly) are the same. This yields the same result. No text wrap or border for the video.