Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Site suddenly disappeared

Go to End

3 Posts   1554 Views


Community Member, 22 Posts

23 January 2014 at 10:12am

We have several silverstripe sites running on a mac server. One of them has suddenly disappeared, showing only a blank page, (polar the rest of them are just fine (e.g.

Error logs say "Fatal error: require_once(Zend/Log.php): failed to open stream: No such file or directory "… etc
We can't find a Zend directory but we can't find it in any of the other sites that work just fine either.

If you try rebuilding the site you get "The requested URL /polarresearch/index.php/dev/build was not found on this server"

We are at a loss as to how to troubleshoot this - my local version is working fine. No one has done anything to the site at all. The only changes to the server have been one MySQL database added, and one of the other sites has had a wee facelift by adding another set of theme files.

Any help would be appreciated, thanks in advance


Community Member, 254 Posts

23 January 2014 at 12:25pm

The Zend/Log.php file sits in {SS install}/framework/thridparty/Zend/Log.php

I'm trying to see what it could be, missing htaccess or something.... something must have happened for it to suddenly disappear.


Community Member, 22 Posts

28 January 2014 at 3:55pm

Edited: 29/01/2014 2:41pm

Yes, something must have happened, but we have no idea what. I still get the white screen and same error after having completely replaced the website files with the local copy, and also when I steer the thing at a different copy of the database.

I should add, we're using SS 2.4. and don't seem to have any directory {SS install}/framework or {SS install}/sapphire/framework or any other framework directory for that matter.

Update: It is all fixed. Needed to add paths for php to find the Zend directory. I still can't figure out HOW the other sites are still working without such instructions added, but they are. At least I'll know how to fix them if they go belly up too.