Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Translate site


Go to End


3 Posts   1432 Views

Avatar
pjssms

Community Member, 49 Posts

8 January 2009 at 1:01am

Hello,

I have created all the pages in Portuguese as well as the names of the pages.

I have used instructions on http://doc.silverstripe.com/doku.php?id=multilingualcontent&disqus_reply=4958678#comment-4958678 and now i have the option to add more languages.

I was able after the rebuild to go to all the first level pages and clic to have a translation of the page. It has automatically copied all the data to the new version.

However it doesn´t show the second level pages.

I add to switch back to english version, then select a second level page and just then i got a new page in portuguese.

However now the system shows on the left column one english and TWO portuguese versions.

Would that work like that ?

How do i say to the system that all my pages are in Portuguese and that the default language is portuguese ? Should i create the portuguese version of all the pages first ?

I think i will need to something like:

Add the following code at beginning of "cms/_config.php" and of "sapphire/_config.php":
i18n::set_locale('fr_FR');

I don´t know the locale for Portugal.

Avatar
pjssms

Community Member, 49 Posts

23 January 2009 at 7:16am

anyone ?

Avatar
Terminator4

Community Member, 81 Posts

28 January 2009 at 6:13am

Sounds like there might also be an SS issue with something that is happening there.

However, the locale for Portugal is: pt_PT