Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Pictures in tables - how to stop them being indented


Go to End


4 Posts   1375 Views

Avatar
Nick29121972

Community Member, 3 Posts

20 January 2009 at 3:53am

Hi

I'm really struggling here. It seems that a SilverStripe table automatically indents an inserted graphic. I have checked all related table/cell/column/row settings and they are at 0. This is a real problem as some of the pages I am trying to import are set up with no indent and the graphics span multiple cells with no gaps.

Does anyone know how to switch off the indent?

Thanks
Nick_Nick

Avatar
dio5

Community Member, 501 Posts

21 January 2009 at 9:09am

Got an example?

If this can't be found in the html source code it must be a matter of changing the stylesheet.

Avatar
Nick29121972

Community Member, 3 Posts

21 January 2009 at 9:06pm

Hi

Thanks for the response. I have attached the site as it should be, then the site as it is when the HTML is dropped in to a regular home page in the CMS, with the tutorial template set up.

There is some indent around the pictures within a cell and there is some indent between a table border and a nested table. Ultimately I don't want there to be any indent/padding/spacing anywhere. Any help much appreciated.

Thanks
Nick

Attached Files
Avatar
dio5

Community Member, 501 Posts

21 January 2009 at 9:22pm

It's hard to say from a website dropped in a .doc file :) but I expect this to be because of a lack of / different settings in certain style declarations in the stylesheet. (vertical-align:top; (for table cells)).

I'm not sure what exactly you dropped in the cms content, but I think you'll need to ask the developer who created your site to change this, or if you got access to your stylesheet, add in:

td{
vertical-align:top;
}

Might already help some things.

But be aware that this may cause other stuff to look weird if your site is built with tables (which it shouldn't).