Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Create a new translation

Go to End

8 Posts   1851 Views


Community Member, 2 Posts

31 January 2009 at 2:28am


I have problems starting a new translation (faroese).

First I log in with my account to the translation server, and select to start a new translation (faroese). After filling out the first page, I hit the "Save All"-button. But it returns this error message every time: "Error saving content".

Any hint on what is the cause of this issue is appreciated.


Community Member, 22 Posts

3 February 2009 at 12:16pm


I have the same error, which happens here as well: (page edit > translations > add langauge)

Please find attached the error log from my installation. I seed that this is caused by a wrong mysql query.
I hope someone has an idea to fix this because this is an really important issue in my opinion.

Thanks and best regards,

Attached Files

Community Member, 16 Posts

23 February 2009 at 12:11am

Edited: 23/02/2009 12:13am

Same here.

This is what I did:

* Installed 2.3.0 RC4.
* Copied my old site back into the installation folder (previous version was 2.2.3).
* Everything works fine, browsing the site, logging into the CMS, creating and editing pages and so on.
* I enabled multilingual support using the Translatable::enable(); directive.
* Ran /dev/build, new tables were correctly created.
* In the CMS I select a page, go to the Translations tab, select Swedish and click Create.

The error that is logged is attached to this post.

Attached Files

Community Member, 16 Posts

23 February 2009 at 12:44am

As a side note, I just tried installing a clean 2.3.0 RC4, installing the demo site and enabled multilingual support and received the same problem. Seems like a bug to me?


Community Member, 16 Posts

23 February 2009 at 9:08am

Latest trunk (silverstripe.2.0.DailyBuild.2009-02-23) seems to have a crippled translation support.

After a successful installation of demo site and enabling multilingual support (Translation::enable() in _config.php file), running /dev/build gives the following error:


[Notice] Undefined index: Lang
GET /silverstripe/dev/build?flush=1

Line 352 in C:\Program Files\wamp\www\silverstripe\sapphire\core\model\Database.php


I'm not familiar with reporting things like this. Should I do this, if yes, how do I go about doing this?



Community Member, 126 Posts

23 February 2009 at 10:04pm

bugs are collected in the bug tracker (, anyone can create an account there and submit tickets (


Community Member, 36 Posts

26 May 2009 at 3:46am

Hey everybody!

Anyone could find the error? i have exactly the same problem with the latest version of silverstripe. If someone found it plese help me!



Community Member, 904 Posts

26 May 2009 at 4:12am

Well.. What is this latest version you're referring to? If it's anything like 2.3.0 or 2.3.1 it won't work because of the previously posted bugs. You'll need 2.3.2. You can get RC1 here: