Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

page type troubles: can't get access to certain pages or save content anymore

Go to End

4 Posts   1366 Views

wilhelm oder wil er nicht

Community Member, 16 Posts

19 February 2009 at 5:11am

Edited: 19/02/2009 11:40pm

aye, hi there. I'm not as familiar with Silverstripe as I'm supposed to but I'm on the way, hopefully.
The thing is I've got troubles with my homepage type. I simply created a new page type called homepage, and tried to applicate it on a site at the backend. while I was save&publishing the whole thing, it cracked down. I checked the database and it's all fine, somehow I finally noticed there must be something wrong with homepage.php (check out the attachment) which is still kinda weird because I used this for several other sites and they worked. So I thought there might be something wrong with the encoding of my editor, and well, it really was but after fixing that I still got the same problem: I still can't save any content at the cms and I can't get access to "home" at the backend (an alert box only says "there has been an error"). does anybody of you have an idea what might be wrong?
I'm looking for the mistake all day long so I'd be happy if I could get some help. I'm sure it can't be that heavy...


Community Member, 97 Posts

19 February 2009 at 2:10pm

I can't see anything obviously wrong with this code.

Have you rebuilt the database and flushed SilverStripe's cache?

Your next step should probably be to find our more about what is going wrong.

I suggest you:

Turn on SS's debugging mode:

Install Firebug (for Firefox) and see what it can tell you about the failing AJAX calls:


wilhelm oder wil er nicht

Community Member, 16 Posts

20 February 2009 at 1:36am

Edited: 20/02/2009 1:38am

hey, thanks for answering.
yes I know about the db build and the flush. the thing is, that Page.php and HomePage.php kinda don't fit together. Together they don't work but if I only use one of them I don't have any problems. Well, I need to get some work done and I might be able to manage it with one page type for the moment. I definitely will get back to that problem when the time has come...
I don't think it's something you can figure out by debugging or firebug which I already used but maybe I'll get back to that again later. thanks anyway!

wilhelm oder wil er nicht

Community Member, 16 Posts

20 February 2009 at 4:19am

uuh, new note when db/build/
# Notice: Undefined variable: suffix in /home/dahinden-holz/ on line 249 Notice: Undefined variable: suffix in /home/dahinden-holz/ on line 250 Notice: Undefined index: _obsolete_homepage2 in /home/dahinden-holz/ on line 249 Table HomePage: renamed to _obsolete_HomePage2

when and why did THAT happen?