Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Login Problem

Go to End

15 Posts   3595 Views


Community Member, 904 Posts

12 May 2009 at 4:53am

Are these javascript files really in /assets ? When I grab the latest SilverStripe from SVN, there's not a single .js file in /assets. And I can't seem to find base.js either... so where is it coming from?

Either way: Did you set the permissions of /assets to at least 755 and the javascript files to 644?


Community Member, 19 Posts

12 May 2009 at 6:09am

Who are you hosting with? You may want to double check that the server that's hosting your site meets the recommended requirements for SS to run smoothly.

I had a totally bizzard problem with login in as well and came to realize that my host did not play nice with SS so I switched to a host that better fit the requirements (hostmonster) and have not had a problem since.

Hope you find this helpful.



Community Member, 14 Posts

12 May 2009 at 7:30am

Edited: 12/05/2009 7:30am

Thanks Andre,

However I think my host (1& is OK. I didn't haven't had any trouble until running a combination of 2.3.2b1 and a new theme together.

I've been doing some testing on my MAMP dev site, creating 'virgin' installs using different combinations of new and copied themes and I have noticed some things related to the 'assets' directory that appear repeatable and some not.

However I need to go back and re-test more methodically to confirm things, so I'll report back later on tomorrow when I have retested and rechecked everything to see what is and isn't in my imagination. :-)

Thanks for the suggestions and support so far.


Community Member, 19 Posts

12 May 2009 at 7:33am

Sounds good, i'll stay tuned :-).


Community Member, 14 Posts

13 May 2009 at 7:52am

Edited: 15/05/2009 2:51am

--- Edited by Lokash20 13/05/2009 18:44 ---

I've trimmed this post as it's no longer relevant to the thread.


OK, so how do you get the remove files to work? :)

Attached Files

Community Member, 14 Posts

14 May 2009 at 4:19am

Edited: 15/05/2009 2:52am

--- Edited by Lokash20 13/05/2009 18:44 ---

-- Edited to remove unneccesary clutter --

Either way, I haven't be able to provoke another admin loading page hang.

-- Edited to add --

For the hell of it, I just tried logging in to the mirror testing site I use on my ISP (where I was having the original problem with the Admin loading page hanging) and all is well. I'm in! I wonder what on Earth was happening? Oh well, panic over. Sorry for any hassle I may have caused.

I'm going to trim my earlier post and try to reproduce the other issues I've found. If I can, I'll log them in TRAC.

Thanks for all the assistance, good people. I've learned a lot in a short time. :)


Community Member, 14 Posts

14 May 2009 at 6:00am

Edited: 15/05/2009 2:54am

And now I'm getting irritated. :|

I decided to recreate my tests on my mirror testing site that I use on my ISP and, guess what? I can provoke the admin loading page hang.

I did this sequence twice to check it isn't browser specific:

1) Installed a virgin copy of SS232 with shiny new back-end DB on my ISP account
2) Logged in as admin
3) Created pages & translations, deleted & renamed pages, making sure to log out and back in each time to make sure all was OK
3) Logged out once again
4) Quit and restarted the browser
5) Tried to log in and sat watching the admin loading page for 30 minutes with no change
6) Manually navigated to Security/login and it told me I was logged in
7) Manually navigated back to /admin and it was still hanging
8) Did a ?flush=all to no avail
9) Did a Db sanity check to no avail
10) Gave up to come and report here

If anyone can reproduce this error, please post in this thread.

Go to Top