Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Warning: Warning: there are two 'BulkLoader' files both containing the same class


Go to End


2 Posts   1887 Views

Avatar
xcommum

Community Member, 10 Posts

27 March 2009 at 2:36am

I keep getting this error every now and then when I visit our site with SilverStripe installed: Warning: Warning: there are two 'BulkLoader' files both containing the same class: '/home/public_html/sapphire/dev/BulkLoader.php' and '/home/public_html/cms/code/BulkLoader.php'. This might mean that the wrong code is being used. in /home/public_html/sapphire/core/ManifestBuilder.php on line 253

If I open the Manifest Builder.php file line 253 is: user_error("Warning: there are two '$itemCode' files both containing the same class: '$folder/$item' and '{$classMap[$itemCode]}'.
This might mean that the wrong code is being used.", E_USER_WARNING);

I have installed 2.3 overtop 2.2 and then reverted back to 2.2 because of issues we were having with 2.3. Any suggestions on a fix for this?

Avatar
xcommum

Community Member, 10 Posts

27 March 2009 at 2:43am

I noticed there was an extra folder in /sapphire called "dev". Not sure if this folder is proprietary to 2.3 and not 2.2, so I deleted the entire "dev" folder (since I am running 2.2 again) and it took the error away for the time being, not sure if it will return or not, I will let everyone know.

For the time being this seems to be where the problems are..