Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Blank Page of Death on Admin Page

Go to End

23 Posts   6648 Views


Forum Moderator, 4102 Posts

14 April 2009 at 4:50am

Thanks for understanding. I don't mean to be harsh, but I spend a lot of time offering support in the forums and it's frustrating to go back and forth guessing about something.

Glad you got it working. Hopefully that doesn't sully UNIX for you too much. I think once you get to know the OS better you'll never go back. :)


Community Member, 245 Posts

14 April 2009 at 4:59am

Actually, this is my fifth Unix SilverStripe deployment-- and i DO love Unix. It's just seems that each box has slightly different configurations, and in this particular one, php.ini was NOT in /etc. I had to do a locate on it, and then I found TWO instances of it, etc. It was kind of a mess. But YEAH-- it's fixed and I'm up and running! Thanks again-- for this and in the past (you have helped me before).



Community Member, 2 Posts

3 June 2009 at 6:47am

Edited: 04/06/2009 6:20am

I also had this problem... found someone to fix it for me now though.


Community Member, 6 Posts

8 October 2010 at 11:45pm

Edited: 08/10/2010 11:46pm

I also had this problem. No matter how much memory I gave it, it would result in a blank page or a out of memory error. In my case this was obviously due to a missing $has_many - statement on the 'other side' of a $has_one - statement. I don't understand how this can be possible since SilverStripe also has $has_one relationships e.g. on 'Image'-Objects without corresponding $has_many - statements in the 'Image'-class...


Community Member, 63 Posts

11 November 2010 at 8:01pm

Edited: 11/11/2010 8:02pm

I got the same thing today. After running the page for nearly a year (2.3.5) yesterday its started to happen

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 232620 bytes) in /home/website/public_html/sapphire/core/Requirements.php on line 630

I increased the memory limit to 256M and it still happens. phpinfo confirms the 256MB mem limit. Code didnt change since a year it just started to happen. It soooooo anoying. could someone give me a hint. cause i tried hard. I tryed to disable the the
Requirements::set_combined_files_enabled(false); to avoid combining. is reachable, but the site tree isnt

I did a build but nothing changed


Community Member, 63 Posts

13 November 2010 at 12:30am


Thank u very much.


Community Member, 63 Posts

19 November 2010 at 11:09pm

and it happened again. Memory Limit is set to 2GB !!!! and i still get this error. phpinfo confirms this value. I have absolutely no idea whats wrong here. Please someone help me in this regard.


Go to Top