Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Blank Site all of a sudden

Go to End

4 Posts   1649 Views


Community Member, 607 Posts

20 April 2009 at 3:59pm

Hi all,

I've inherited a Silverstripe problem from someone else. Version 2.2.3. Last week the site was functioning fine, and there is no info on what happened since then to cause this issue.

The issue is that we get a blank page on every single URL we try. I have tried setting the site into dev mode in config, and using isDev=1 in the URL. (neither will show the login box so I can login anyway). So I can view no errors. Same thing happens when trying to go to the CMS - blank page.

We have a standard .htaccess file. And a php index file responds fine if we comment out the line: RewriteRule .* /sapphire/main.php?url=%1&%{QUERY_STRING} [L].

I have gone through main.php and added a die('debug'); command to see if I can trace the problem and was able to confirm that the problem occurs at a command near the bottom:


I have done a db/build/?flush=1 - output is fine, nothing repaired or reported.

I have cleared cache and done a normal flush on multiple urls.

I have checked my appache error logs in real time and every time a page on this site is loaded, I get the following error:

[notice] child pid 9922 exit signal Segmentation fault (11)

Any further ideas? I've completely run out except for re-installing completely, which will be a major.


Community Member, 791 Posts

21 April 2009 at 12:11am

Huh ? Is apache/php crasing

Did you try the codebase on a different server ?


Community Member, 607 Posts

21 April 2009 at 9:16am

It appears so.

I did try a few other things since my first post:

1. Upgrade Sapphire, CMS and Jsparty to 2.3.1. This kinda worked and the site was viewable again, although there are now a few issues in the CMS. (Tabstrips are dissappearing)

2. Download a fresh copy of 2.2.3 and replace Sapphire, CMS and Jsparty with the files from that archive. Blank page problem occurs instantly.

3. I noticed that this installation also has 3 modules: blog, something calles "SSP", and something called "filemanager". With 2.3.1 basecode installed, I removed filemanager as per a previous post from someone having the same problems in the CMS after upgrading. This works, however now the blog doesn't. Gets and error about "SimplePie" class not being present.

Basically, I think the previous developer has borked this site with untested modules. I think filemanager is the HasMany file manager that I have seen in the forum. No idea what SSP is.

Still looking for ideas. As it stands, the site functions with an upgrade to 2.3.1 and removing filemanager, but the client loses functionality they claim was working, and the blog doesn't seem to be compatable with 2.3.1.

BTW. The hosting server has not changed.



Community Member, 791 Posts

21 April 2009 at 7:07pm

I chose to replace the filemanager with UncleC's dataobjectmanager ; it is a 10 minute job , but the client will need to add the files all over.

However ; although the module development is stopped ; Banal did release a fix to make it work with SS 2.3 ; check out :

The blog module needs to be upgraded to the latest version , you might need to alter some templates for it to work , but it shouldn't be too much of a pain in the *ss....

SSP module.. No idea what that means..... What is in it ? Did you look at the code ?