Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

" Please set upload_temp_dir in php.ini "


Go to End


2530 Views

Avatar
JackAttack

Community Member, 12 Posts

13 June 2009 at 3:19pm

Hi,

I'm getting the following error when I attempt to upload files using the Files & Images tab:

There is no temporary folder for uploads. Please set upload_temp_dir in php.ini

Also when I try to upload using an image field on a custom page type, "File is not a valid upload" appears in the field after pressing Attach File.

I'm guessing both errors are caused by the same problem...

I'm on a shared host that doesn't allow access to php.ini, so is there a way to manually set the temp folder from within SilverStripe?

I read somewhere that SS automatically uses the /tmp/ folder and so I set its permissions to 777 but no good... I've also tried using a _ss_environment.php file (in which i believe you can maually define the temp foleder) but could never get the site to work with it (no input specified error or something). Should I try again?