Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Tutorial - HomePage issues?

Go to End

3 Posts   1218 Views


Community Member, 14 Posts

20 June 2009 at 8:30pm

Hey, I tried SilverStripe a while ago and I think you were between versions 1 and 2. The documentation was for old version of SS and I had some trouble. This time is far better but I am having a little trouble with tutorial 1.

I have added the HomePage page type to the site/code folder. I have then done the admin dev flush thing. A new page option appears called 'Home Page'. This differ's slightly from the option 'HomePage' which appears in the tutorial. When I add the template into the tutorials folder and refresh the page nothing happens. I had added ?flush=1 but still no joy. I check the source and it is definately showing the template file.

Any ideas?


Community Member, 14 Posts

20 June 2009 at 8:33pm

I was at this for about 40 minutes last night. I solved it by randomly clicking around this morning.. instead of saving the page as the js popup appears to suggest you need to hit the save and publish button.


Community Member, 3 Posts

8 December 2009 at 3:09pm

Thank you Jason, that has been such a nightmare for the last hour trying to work out where I have gone wrong.

I hope they update that soon for all the newbies.