Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Tutorial 2: RSS feed error

Go to End

3 Posts   1393 Views


Community Member, 33 Posts

24 July 2009 at 12:23pm

I am trying to create a RSS feed following the instructions in the second tutorial. When I try to access it via: http://localhost/mysite/news/rss (my site being "holybasil"), I get the error:

"[Warning] Cannot modify header information - headers already sent by (output started at /Applications/XAMPP/xamppfiles/htdocs/holybasil/mysite/code/HomePage.php:25)
GET /holybasil/news/rss

Line 188 in /Applications/XAMPP/xamppfiles/htdocs/holybasil/sapphire/api/RSSFeed.php

This is what my ArticleHolder.php looks like:

* Defines the ArticleHolder page type
class ArticleHolder extends Page {
static $db = array(
static $has_one = array(
static $icon = "themes/canvas/images/treeicons/news";
static $allowed_children = array('ArticlePage');

class ArticleHolder_Controller extends Page_Controller {

function rss() {
$rss = new RSSFeed($this->Children(), $this->Link(), "The coolest news around");



Any help would be appreciated,

PS: I've tried Firefox 3 and Safari and I get the same error.


Forum Moderator, 5523 Posts

24 July 2009 at 2:43pm

...... (output started at .../mysite/code/HomePage.php:25)

Output started at HomePage sounds like you have an echo or some whitespace or something else which is outputting content on line 25. Make sure you have removed all your whitespace after the ?> in that file


Community Member, 33 Posts

25 July 2009 at 5:33am

Thanks for the quick response. Following your suggestion, I got the RSS feed to work.

Much appreciated,