Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

All images gone after imagesupload tutorial

Go to End

2 Posts   925 Views


Community Member, 42 Posts

1 August 2009 at 2:40pm

Edited: 02/08/2009 7:57am

I'm feeling like a bit of a dweeb these days with regard to my Silverstripe capabilities, so this could be yet another problem that has a simple solution. But, as I can't figure it out, I appreciate in advance any help.

I followed the advice the imagesuplod recipe (, and it worked to add the field and allow me to upload my banner photo. The photo appears just fine.

The problem is that now all my other images are gone.

After trying all I could figure out to try, I removed the field, rebuilt the database, and then tried again.

The images are still gone.

I removed the variable from my I've double-checked, made test changes to, and replaced my CSS. I've flushed the cache (/?flush=all) and deleted the obsolete files in the database.

What am I not considering?


Community Member, 42 Posts

2 August 2009 at 8:08am

Edited: 02/08/2009 8:10am

The solution is, in part, based on the fact that I am sometimes/often a dork and that I overlooked the duplicate calls to the CSS shown here:

Someone may be able to explain how simply adding an image field would make this not work after it HAD been working, but I'm happy to have it working.