Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Memory Run Out

Go to End

4 Posts   2420 Views


Community Member, 2 Posts

3 August 2009 at 1:04pm

I know there are heaps of comments on this subject already. I simply tried to add a redirect subpage to my site. So it was the 3rd page in the branch so to speak. Since then I've got this error

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 4864 bytes) in /var/www/virtual/ : eval()'d code on line 1

And cannot access any of the subpages online, but I can still change them when signed in through the Admin area (except the inital redirect page). I've tired adding the line


to some fo the php files and no effect.......does anyone know the solution and put it easily for a non-computer person???

i tried juist deleting the extra page I added but again - still no effect.

Digital Punk

Community Member, 51 Posts

3 November 2009 at 3:02pm


have you found where was a problem? I have the same problem too....


Community Member, 45 Posts

3 November 2009 at 3:52pm

Hery Dalboy,

It looks like the memory limit configuration you are hitting is from the php.ini setting. The current limit that you are bouncing off is 128MB, so while attempting to force the ini_set to 64M is valid, its still lower than the core configuration.

You can raise the memory setting in php.ini bu finding the following line;

memory_limit = 128M ; Maximum amount of memory a script may consume (128MB)

and changing it to

memory_limit = 196M ; Maximum amount of memory a script may consume (196MB)

You are only attempting to allocate another 4k of memory to the process, so you should not need to raise the limit too much.

Depending on the OS you are running, php.ini will be in /etc/php (RHEL) or /etc/php5 (Debian).


Digital Punk

Community Member, 51 Posts

3 November 2009 at 10:09pm

Thanks for your answers. It seems that my server provider ( has special settings for php - this is line in .htaccess regarding memory limit:

RLimitMem 128000000

Hope this info will be useful for somebody :)

Now it is working everything. I love this CMS!