Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

New image folders failure

Go to End

7 Posts   1563 Views


Community Member, 17 Posts

1 September 2009 at 1:12am

Hi there,

In my CMS if I try to create a new image folder I get a folder creation error message, and can see no new folders in the list.

But when I log off and then log in the next time the folders are actually there.

Anyone any ideas of a solution to stop this happening???



Community Member, 191 Posts

1 September 2009 at 8:09am

This sounds vaguely familiar. So you click the Files & Images tab, then click Create and then you get the error? Or you get the NewFolder folder, change Title, hit Save Folder Name, and then get the error?

Are you running an old version of SS? What does the error say? Does it happen on Localhost and/or your Webserver? Have you tried using multiple browsers? What are the permissions on the Assets folder, mine is set to 755.


Community Member, 17 Posts

1 September 2009 at 7:09pm

Thanks for the reply.

Nope - the Silver Stripe is brand new I only installed 2 weeks ago.

I've attached a couple of screen grabs that might help.... so what happens is this:

1 - Click to create new folder
2 - Little error message appears at the bottom of the screen (see screen grab) - no folder is created in the list
3 - Logout
4 - Log back in
5 - Et voila, there are the new folders in the list (see 2nd screen grab).

It is very bizare.

I've tried in IE and in FF and it does the same thing - running on a live website in a sub domain.

Permissions on the assets folder is the same as yours 755.


Community Member, 191 Posts

2 September 2009 at 5:25pm

I looked through old posts and the bug tracker and couldn't find out any more info. I double checked my recent install of 2.3.3 and didn't have any issues (Safari and FF on Mac).

Maybe it's just a bad install. If no one else has any suggestions, then maybe you should re-install. When installing, they say to unzip the SS file on the server. If you copied all the files up there, maybe something went wacky or some other permissions were changed.

Samba Sam

Community Member, 85 Posts

15 February 2010 at 2:15am

Edited: 15/02/2010 2:18am

I am getting the same "create folder" error with SilverStripe v2.3.6 installed on my XAMPP localhost. I don't get the error when using SS with my online server account. Previous SS versions worked fine in XAMPP. I thought upgrading XAMPP could possibly solve the problem. It made no difference. I've also tried chmod -R 777 to give full read/write permissions to all the files.

Using Director::set_environment_type('dev'); in my config file doesn't give any more error info.

Anyone have any ideas?



Forum Moderator, 922 Posts

4 March 2010 at 1:38pm

Have you guys tried using in Firefox to see what the error is? The error happens during an AJAX request - you won't see the error unless you have the console in Firebug open while adding the folder.


Community Member, 17 Posts

5 March 2010 at 3:43am

Hi All,

Just to let you know this issue resolved itself as soon as I put the site live into it's main root folder.

So if anyone is seeing the same issue and they're working on a local server or sub domain then maybe this is the reason, and it might just right itself when the site is live online.

Sorry I couldn't offer a technical reason as to WHY, but at least I had a solution to the problem.

Good luck