Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Uploaded images not appearing in "Insert Images"

Go to End

5 Posts   1097 Views


Community Member, 68 Posts

7 September 2009 at 2:46pm

I have created new folders under Files & Images and uploaded images successfully. However, when I go to insert them, the new folders are there but not the images that have been uploaded recently. Images that were uploaded a while ago are visible.

Am I missing something obvious here or is it a bug?

Any pointers would be welcome. Thanks.


Community Member, 68 Posts

8 September 2009 at 2:47pm

The images that are available for inserting in the CMS have thumbnails etc in a _resampled folder that is within the specific folder. Images that have been uploaded recently have a "croppedimage" file only under a generic _resampled folder (under assets folder). These images are not there when I try to insert them in web pages.

Any ideas please?

Bruce B

Community Member, 164 Posts

8 September 2009 at 5:18pm

Did you upload the images directly via FTP rather than through 'Files and images'? If so, you should open the 'files and images' tab. That will update the database and your images should be available for use.


Community Member, 68 Posts

9 September 2009 at 10:04am

I had been loading them through Files & Images. My site is on localhost so I have just tried creating the folders and copying the images into them and then opened Files & Images. It has worked! Thank you.

Files & Images has worked in the past so I am wondering if things went wrong when I upgraded SS to the latest version.

Thanks again.


Community Member, 545 Posts

9 September 2009 at 3:50pm

Make sure your Assets directory and all subdirectories permissions are set to 755, or even 777. I was having the same problem on 2.3 until I set it 777.