Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Overriding default translation tables.


Go to End


987 Views

Avatar
sphire

Community Member, 6 Posts

8 October 2009 at 10:26pm

Edited: 08/10/2009 10:34pm

Hi there,

the situation is as follows: SilverStripe assumes user credentials to consist of an email address and a password. That is fine for sites with various users but often not quite relevant for sites with a closed group of editors. So, to make it a little less confusing I’d like to go with username and password which is not a technical problem as the email field accepts non-email strings anyway.

Now I want to update the language files to reflect this change, e.g.
$lang['de_DE']['Member']['EMAIL'] = 'Benutzername';

The problem seems to be, however that my custom language file (in mysite/lang/) gets included before the core’s. Thus, my custom setting gets overriden by the default one. Obviously I could just change the core but I don’t consider that a particularly good option.

So, is there a reason for the way this works? Are there workarounds?

Any help would be appreciated.

..Philipp

UPDATE: An easy—if not very elegant—workaround apparently is to create a module with a name that is lexicographically “greater” than “sapphire” and put the language file there (which also seems to indicate that this was not a conscious design decision).