Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

[Solved] Login and Assets-Files in IE8


Go to End


6 Posts   1815 Views

Avatar
StartUp3D

Community Member, 10 Posts

28 October 2009 at 1:13am

Edited: 04/11/2009 1:07am

Hi there,
since a few days i got some problem with one of my customers Silverstripe-Hosting (hosting at Strato in Germany):

If I watch the site via Opera or Firefox all of the assets-files are shown. Additionally the administration-login works with no problem.

If I watch the site via Internet Explorer 8 all of the images and files, uploaded via assets-management ar not shown. The path for the files is correct. Additionally the administration-login fails, because i got redirected after entering my login-data to the address ".../Security/Security/LoginForm". Normally that should be ".../Security/LoginForm".

In my base-htaccess-file i got "RewriteBase /". Also i got the "<base href"-tag in my page.ss-file.

One thing that came into my mind was the missing "Slash" for the path of the assets-files. But how can i tell Silvertripe to put a single "/" into my assets-files i´m putting on the site?

If you want to take a look at the problem please visit http://www.geiger-personalconsult.de (for example the Image under the menue "vita")

Maybe someone can help me out here.

Thank you in advance for your effort,
Otto

Avatar
baba-papa

Community Member, 279 Posts

28 October 2009 at 9:24am

You login via /Security/login.

Avatar
StartUp3D

Community Member, 10 Posts

29 October 2009 at 3:46am

I know, but it´s redirecting me to ".../Security/Security/LoginForm"

I think it´s because the previous "/" is missing. At the image-path AND also at the form-action-path. So IE8 is not using the root-path (e.g. http://www.geiger-personalconsult.de/), instead it´s using "http://www.geiger-personalconsult.de/Security/".

I have no clue why this is happening.

Avatar
badjedi

Community Member, 25 Posts

3 November 2009 at 11:28am

I am having the exact same issues with a client, using vista and IE 8

Avatar
StartUp3D

Community Member, 10 Posts

3 November 2009 at 8:43pm

As you can see here (http://blogs.msdn.com/ieinternals/archive/2009/07/27/Bugs-in-the-IE8-Lookahead-Downloader.aspx) there is a bug in IE8 called "The BASE Bug". But as you can read it should be fixed already.

Also i´m confused, that it has to do with the bug mentioned above, because other silverstripe-installations on other hosting-partners do not have this problem.

Still have no clue :(

Avatar
StartUp3D

Community Member, 10 Posts

4 November 2009 at 1:07am

Problem solved:

Obviously the file "Page.ss" was edited with an editor who put cryptic special characters before the starting <html>-tag (maybe some UTF-8?). In my editor that characters weren´t visible. Only copying the source-code from the IE8 into my editor made that charactes visible to me.

After i cleaned the file "Page.ss" and uploaded it, the site is rendering without any problem again.

Best regards,
Otto