Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Problems with source html editor


Go to End


2 Posts   940 Views

Avatar
nemoneo

Community Member, 1 Post

3 November 2009 at 5:54am

Hello

I have a Problem with the HTML Source Editor on the Silverstripe admin site.

I want to embbed a Java Applet into a regular Page, but if i paste the applet Tag into the source editor nothing happen.

<APPLET code="Applett.class" archive = "Applett.jar" width=350 height=200></APPLET>

Wenn i reopen the HTML Source Editor the Tag is gone.

What is my fault?

Thanks.

Regards
Michael

Avatar
Mo

Community Member, 541 Posts

3 November 2009 at 7:36am

I think the HTMLEditorField blocks certain html tags (I would imagine for security reasons).

What I usually do is create another HTMLText entry in the model and then just use add a TextAreaField to the getCmsFields() method. The only issues with this are that the applet wont be embeded within your page content, it will either be above or below.

Mo