Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

CRITICAL: Missing / Disappearing Images

Go to End

30 Posts   8429 Views


Community Member, 14 Posts

24 November 2009 at 11:27pm

When I run the images/flush I get:
54 formatted images from 51 items flushed

so looks ok, but still no joy.


Community Member, 791 Posts

24 November 2009 at 11:34pm

@lobo : In my case , the images were definitely not replaced and were placed in a content-block (through tinyMCE) or in a summary-list (which used a Silverstripe Image field that got resized) , so no DOM or image galleries were being used ....


Community Member, 181 Posts

6 April 2010 at 9:36am

Found this thread while looking for something else, this could explain some odd beahaviour I am seeing in a site running on SS v2.3.4
Using the latest ecommerce trunk to host a catalogue of images for a photographer, so disappearing images is a big deal. I will try running image/flush and see what I get.
Anyone else made progress on this in the last 4 months?


Community Member, 1 Post

18 August 2010 at 9:30am

Edited: 18/08/2010 9:30am

This has occurred in our site as well. Any images used on pages from the _resampled folders are now missing.

Silverstripe 2.3.4 with DataObjectManager.

Has this been fixed in any recent patches?


Community Member, 181 Posts

18 August 2010 at 9:46am

Just trying to think how I solved this.

IIRC the issue was with images added to the CMS before SWFUpload was installed. I'm a bit sketchy on the details but removing the images and re-adding them with SWFUpload sorted it for me.

Might not be the same issue you're having but it's one scenario.




Community Member, 49 Posts

21 January 2014 at 11:16am

Apologies for bumping such an old thread, but I am experience identical symptoms on a 3.1 website.

Images uploaded and resized via TinyMCE are having their resampled copies removed randomly.

When the image is resized within TinyMCE, the src path is assets/Uploads/_resampled/ResizedImage600464-<filename>.jpg

Initially, the file saves correctly and the resized image appears. But my client is notifying me that these images are now appearing as broken. Upon further investigation I see that the resampled copy of the image doesn't exist, but the original image does.

The resized files aren't regenerating, and I have to go into the CMS and re-add & resize the original images.

I can't replicate the resized image being removed so I don't know what would be triggering that.

Has anyone else experienced similar symptoms and does anyone have a resolution?


Community Member, 49 Posts

21 January 2014 at 12:07pm

Upon further investigation, an unrelated dev/task/FlushGeneratedImagesTask call is the culprit. This is ran via a cron job on an unrelated task within the same website.

Unfortunately, this results in any images resized within TinyMCE to not regenerate until I republish the page.

Does anyone know of any way to prevent the ResizedImages created via TinyMCE from being deleted while performing FlushGeneratedImagesTask? Or alternatively how they can be regenerated automatically upon calling FlushGeneratedImagesTask?

Any help would be appreciated.


Community Member, 49 Posts

7 February 2014 at 1:36pm

Sorry for the bump - just checking to see if anyone can help with this problem before I stop using FlushGeneratedImageTask entirely.