Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Hosting Requirements /

What you need to consider when choosing a hosting provider and plan.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Plesk + Nginx configuration


Go to End


5 Posts   2240 Views

Avatar
player.c64

Community Member, 3 Posts

18 September 2015 at 4:25am

Edited: 21/09/2015 6:08am

Hi guys,
I just started my adventure with silverstripe. I built new website I'm really excited about this software. First problems appear when I wanted move finished website on VPS server which is running on nginx environment first problem after migration on back end its displaying bad gateway. Second problem url on home page are generated with index.php in the middle on rest pages they are generate url friendly. I've heard nginx+plesk is a pain with configuration but I have no option to change hosting. I tried setup apache but no luck I'm not great with linux. I followed those tutorials: https://www.howtoforge.com/running-silverstripe-on-nginx-lemp-on-debian-wheezy-ubuntu-13.04
https://docs.silverstripe.org/en/3.2/getting_started/installation/how_to/configure_nginx/ <-- this official documentation is a joke sorry.

Thanks.

Avatar
Kirk

Community Member, 67 Posts

18 September 2015 at 10:39am

Can you confirm if you have the Apache mod_rewrite module is installed and running on your VPS server.
It looks like it is not enabled normally it is enabled via the following command

a2enmod rewrite

http://stackoverflow.com/questions/869092/how-to-enable-mod-rewrite-for-apache-2-2

Avatar
player.c64

Community Member, 3 Posts

18 September 2015 at 10:50am

Thanks Kirk for your reply. Module mod_rewrite is enabled :(.

Avatar
Kirk

Community Member, 67 Posts

18 September 2015 at 3:20pm

Another suggestion may be to take a look at your .htaccess file (might need the rewrite base set)
Also found a good page on Stackoverflow which may point you in the right direction.

http://stackoverflow.com/questions/20475176/silverstripe-mod-rewrite-issue-i-think

Avatar
player.c64

Community Member, 3 Posts

21 September 2015 at 6:11am

OK friendly url are running I renamed index.php to index2.php. Only thing is still bad gateway on admin. I followed this tutorial https://www.silverstripe.org/blog/nginx-for-fun-and-performance/. Increased buffer size but still no luck. How can I debug it?