Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Hosting Requirements /

What you need to consider when choosing a hosting provider and plan.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

"File is not a valid upload" could this be a problem with the server


Go to End


7 Posts   6721 Views

Avatar
Optic Blaze

Community Member, 190 Posts

23 September 2010 at 7:59pm

Edited: 23/09/2010 8:19pm

Hello. I have been using SS2.3+ sucessfully on the hosting platform that i use in South Africa. I recently started working with SS2.4+ but i keep on getting "File is not a valid upload" errors when attempting to upload files/images after doing fresh installs on the host server. On my local machine that runs WAMP, everything is perfect.

I have checked the forums and most of the posts relating to this issue is really old and i would assume would have been dealt with already in the new version 2.4.2. The only thing that i can think of is that there is a hosting parameter that my provider does not meet.

I have dowloaded SS2.4.2 and the same problem persists. It is only the file uploads that does not work, the rest of the CMS is perfect.

I have attached the phpinfo() file in pdf format

Please help

Attached Files
Avatar
charden

Community Member, 7 Posts

23 September 2010 at 8:21pm

Hello,

Your problems are probably caused by a PHP open_basedir restriction set by your service provider. This patch should help you get up and running: http://open.silverstripe.org/attachment/ticket/5547/2.4.1-FileUpload-2.diff

You may also want to check out the ticket for the issue and this forum thread.

Good luck.

Avatar
Optic Blaze

Community Member, 190 Posts

23 September 2010 at 9:02pm

ITS ALIVE!!!!! Thanx man it worked...i was ready to start slashing my wrists of frustration.

Avatar
schellmax

Community Member, 126 Posts

26 March 2011 at 4:10am

worked for me too (on 2.4.5, although the line numbers were not exactly the same).
thanks for sharing!

Avatar
rotamota

Community Member, 4 Posts

5 July 2011 at 12:58pm

I prefer this method rather than modifying code if you have WHM:

Login to the WHM panel >> Main >> Security >> Security Center >> open_basedir protection
Here you can Disable/Enable the protection for particular domain or server wide.

Avatar
shimi

Community Member, 1 Post

8 July 2011 at 7:57am

We should carefully upload files in content

Avatar
bk

Community Member, 2 Posts

7 June 2012 at 1:46am

I am having the same problem in 2.4.7. the patch didn't work for me, I am getting this error also (attached image)

everything works perfect locally. Any ideas?

Attached Files