Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Hosting Requirements /

What you need to consider when choosing a hosting provider and plan.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Hosting issues


Go to End


4 Posts   2131 Views

Avatar
breandano

Community Member, 7 Posts

4 March 2009 at 3:47am

Hi there,

I have managed to find a host for my irish site, and things appear to be going well in the main.
However, I have come across 2 issues which may or may not be of my own doing.

When attempting to upload files and images, I am getting a permission denied error, my web hosting has told me that i will need to ftp all of my files up, as silverstripe is using a 'nobody' user, which the server does not recognise.

The other issue is with the i18n translations tab on pages - when trying to add a new language, I get a 'Server Error'.

As background, I am logging into admin using http://muscrai.ie/sapphire/main.php?url=admin/ , as using a direct url/admin conflicts with the webhost.

Could this be the issue?

Regards

Breandan

Avatar
JZM

Community Member, 34 Posts

4 March 2009 at 6:02pm

Hello Breandan,

Have you checked your CHMOD settings for the following issue:

When attempting to upload files and images, I am getting a permission denied error, my web hosting has told me that i will need to ftp all of my files up, as silverstripe is using a 'nobody' user, which the server does not recognize.

Jess

Avatar
breandano

Community Member, 7 Posts

5 March 2009 at 5:11am

Hi Jess,

Many thanks, once I changed the permissions, I could upload!

My only other issue now is with translations, but we'll get there!

Thanks once again

Avatar
martimiz

Forum Moderator, 1391 Posts

6 March 2009 at 12:09am

Edited: 06/03/2009 12:10am

There still seem to be some issues with multilingual content in version 2.3. See http://www.silverstripe.org/silverstripe-2-3-0-released-1000s-of-improvements/ where it says: Warning about translatable content