Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

cPanel hosting and file permissions

Go to End

12 Posts   6974 Views


Community Member, 224 Posts

15 January 2010 at 6:57pm

This seemed like a good place to add this.

I too have just upgraded to a new WHM dedicated server from a shared reseller.

I am getting errors when entering my domain name, like the system is not seeing the index.php file. Might be some mime issue there.

When I enter install.php the installer comes up, but for some reason looks very strange - see attachment. Maybe you guys have run into this before.

Any ideas?

Thank you,

Attached Files

Community Member, 224 Posts

15 January 2010 at 7:06pm

I disabled the PHP open_basedir and now index.php loads the install.php file fine with no errors. However, it still looks like the image I included.

Keep digging...


Community Member, 63 Posts

16 January 2010 at 1:01pm

Hello Steve,

Check the database name is correct. On my cPanel when I installed a new db it would enter a dbname. The Database is actually called by the username _ dbname so was not dbname but in fact username_dbname.

The reason I mention it is it took me ages to realise the db was not the name I thought at the time.

If that does not work create a test php page called test.php and put the following code into it to check

<?php phpinfo(); ?>

This should let you see all the set up for the server, and may pop up other problems.



Community Member, 224 Posts

16 January 2010 at 3:28pm

Thank you Chris,

What I did was add the right info into the little fields carefully and installed the CMS.

Then after I uploaded the files to 'cpanel3-skel' under the main server, my next installs worked just fine and the screen as shown here did not return. Might have been something in memory causing this.

Yes, in cPanel the user name (ftp login) always goes before the db and user name on install

Go to Top