Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Re-installation on WAMP - Unknown class passed as parameter

Go to End

6 Posts   2857 Views


Community Member, 607 Posts

30 November 2009 at 9:31pm

Edited: 30/11/2009 9:31pm

Hi all, this is a weird one and can only assume it has something to do with SS cache.

I had a working copy of 2.4a on WAMP and it was working fine. I decided to go back to 2.3.3 for this sandbox, so cleared the webroot, emptied the DB and copied a fresh set of files to the webroot.

First, the installation redirect went to http://silverstripe.localhost\/install.php which obviously caused an error. I delete the backslash and all is as normal.

I go to the next installation step, and at the point where it is "building database schema" an error is thrown:

The title of the browser also says "PHP 5 is required".

I have installed many times on this exact WAMP installation, and it is running 5.2.5.

Any ideas? And just where are the silverstripe-cache files on a WAMP installation anyway?

Attached Files

Community Member, 28 Posts

1 December 2009 at 1:04pm

Edited: 01/12/2009 1:08pm


would like to join this, although my installation is on MAMP.
Noticed that installation failed with same error, using version 2.3.2, 2.3.3 or 2.3.4 (tonight). Did some testing and found out (and thought, maybe it has to do something with it):

Installation failed on Virtual host www.anwaltsinstitut.msh. Installation passed without error by installing these three versions without putting any virtual host and using only the normal folder name after extrating the files from .tar (e.g. Silverstripe-v2.3.3). Tried to rename the folder to named virtual host without success. And then i tried - tested already in version 2.3.2 and 2.3.4 right now - renaming the folder Silverstripe-v2.3.4, which with URL localhost/Silverstripe-v2.3.4 worked, but used new virtual host www.anwalt.msh. This ist much shorter, so maybe it has to do with friendly URL thing and throws only the "unknown class passed as parameter" error, when URL is to long ?

Just a guess - have no clue....



Community Member, 607 Posts

1 December 2009 at 1:18pm

Edited: 01/12/2009 1:18pm

Hi mate,

The only way I got around this is by installing in a different physical directory, with a new database, and a new URL.

I still suspect this is a cache issue. But I cannot for the life of me find where WAMP stores silverstripe-cache files on Windows.


Krille Brocket

Community Member, 10 Posts

2 December 2009 at 9:20am

Edited: 02/12/2009 9:22am

I'm running XAMPP and had the same problem.

To get it working i deleted the silverstripe-cache & silverstripe-cacheC*** folders under C:\Documents And Settings\[your user name]\Local Settings\Temp folder


Forum Moderator, 922 Posts

2 December 2009 at 10:11pm

FYI, I fixed a bug with the cache/temp dir on Windows here:

It'll appear in the next 2.4 release - if you want, you can switch your cms and sapphire to branches/2.4 from SVN, which is where the 2.4 development is happening.



Community Member, 10 Posts

15 January 2010 at 1:53pm

FYI this is not just a windows problem, the exact same thing happened to me using ubuntu. Following advice in this thread I cleared out the silverstripe-cache folders in my /tmp directory, seems to be fine now.