Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

db/build?flush=1 doesn't work

Go to End

5 Posts   7837 Views


Community Member, 98 Posts

6 January 2010 at 7:33am

I've installed SilverStripe on a linux server, downloaded, extracted and placed the events_calendar folder in the root of silverstripe, and placed db/build?flush=1 at the end of my URL, and no matter what combination of this suffix I append, I get "Object not found". I've also loaded Silverstripe on a Windows XP computer using XAMPP and everything worked perfectly, so I am at a loss as to why I can't flush and get the calendar working. Does anyone have any suggestions?


Forum Moderator, 5523 Posts

6 January 2010 at 9:14am

Can you post a screenshot for the error. Also for rebuilding the database on the front end the 'proper' one is to use /dev/build rather then db/build but it should work both ways.

Does SS work without the event_calendar folder? Just a simple installation.


Community Member, 98 Posts

6 January 2010 at 9:24am

Hi Willr! Well, I just tried it again (for the 532nd time!) to create a screen shot for you, and... it worked this time! I have no idea of anything that I did differently than the previous 531 times I tried it, but for some reason it worked this time, and I will now go ahead and try to make a calendar. Thank you for your reply - I just wish that there had been something helpful I could have offered as an actual solution. Oh, and yes, the ss worked quite nicely without the event calendar, although I had fits making it believe that the mod_rewrite was actually installed and that Allow Overwrite was all, but other than that it does work very nicely. Thanks again.


Community Member, 1 Post

25 May 2010 at 5:48am

i`am not really understand with db or dev ?flush=1 ,but i ve succesfully with flush just one time..n now i got failed...
i`am use xampp for this..i ve web directory with the name i `am get flush thenew page with like this http://localhost/silvertripe/build?flush=1
but this get an error..n said wrong directory somethin like that..or path is wrogn or not exist..,oh yeahh i put the HomePage.php at /mysite/code/ directory as tutorial silverstripe said..but its failed..what must i do??? thnnks


Community Member, 1 Post

11 November 2013 at 1:24am

Hello there,

altough this post is a bit old, I think it's good to have my 5 cents here for future users.

I had the same problems. And it turned out that url_rewrite was not working properly for the directory where silverstripe got installed.

The installer already gave me a warning, but I ignored the information that friendly URL is not working. (That should at least give an warning on the first page of the installer!).

Friendly Urls are required for stuff like dev/build to work. The problem was my apache 2.2 configuration - the root folder had AllowOverride None set. After changing that to AllowOverride All (in /etc/apache2/sites-enabled/000-default) I reinstalled silverstripe and everything went fine this time - no error messages about friendly URL's.

In the end it was possible to call dev/build?flush=all

This gave me a few moments of doubts - it should be made more clear how important url rewriting is. Here someone describes how to test if url_rewrite module is working: