Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Can't install SS 3.2.1 on OVH server due to an issue with PDO connection


Go to End


3 Posts   1713 Views

Avatar
Digitweaks

Community Member, 11 Posts

26 January 2016 at 6:26am

Hi everyone,

i been unable to install SS since version 3.2 and the PDO connection implementation.

I tested the PDO connection by adding a php script straight on the server and it shows that i CAN connect via PDO.
However, when i install SS 3.2 with a fresh install i always have that error

Access denied; you need (at least one of) the SHOW DATABASES privilege(s) for this operation
PDOConnector.php:337

If anyone may help, i tried everything, check everywhere, doesn't make sense to me
Thanks

Avatar
Digitweaks

Community Member, 11 Posts

26 January 2016 at 7:19am

Installation works and the issue been solved by doing the modification explained on this topic https://github.com/silverstripe/silverstripe-framework/issues/4765#issuecomment-155904468

On https://github.com/silverstripe/silverstripe-framework/blob/3.2/model/connect/Database.php#L632 you can remove all of the code except for the last line, and you should be able to connect again.

Avatar
Over-Thinker

Community Member, 7 Posts

13 February 2016 at 5:56am

Hi All,

I have this same issue installing 3.2.1 on a cloud server.

Could someone expand on the remedy actions mentioned for this issue. I'm struggling with this one.

Thanks.