Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Zend/Log.php line 46 errors in 2.4 rc1

Go to End

3 Posts   2412 Views


Community Member, 203 Posts

9 April 2010 at 12:15am

Is there someone who can help me with this? When installing and when giving a dev/build I get:

Warning: require_once(Zend/Log.php) [function.require-once]: failed to open stream: No such file or directory in /srv/www/htdocs/ on line 46

Fatal error: require_once() [function.require]: Failed opening required 'Zend/Log.php' (include_path='.') in /srv/www/htdocs/ on line 46

All tables are in the batabase but remains mostly empty

/sapphire/dev/Log.php, line 46 = require_once 'Zend/Log.php';

include_path seems to be set to '.' and stays that way (tried setting and getting the include_path with code from core.php but it stays at the old value)

Security is very tight, they are using open_basedir, can not even do a php_info so I can use their settings and reproduce the error on my own system. (Tried to use open_basedir on my own system, but that did not reproduce the error).

I will try to play some more with it. Maybe adding the include_path to my _config.php or elsewhere? Dunno...

Thanks in advance


Community Member, 203 Posts

9 April 2010 at 12:36am

Edited: 09/04/2010 1:10am

Noticed I can reproduce the error by commenting out lines 186 through 190 in Core.php

EDIT: In my .htaccess I have created the following php_value:

php_value include_path "/Users/yurigoul/Sites/sapphire:/Users/yurigoul/Sites/sapphire/parsers:/Users/yurigoul/Sites/sapphire/thirdparty"

But the error remains. Anyone knows what I am missing here?

my bad typo (isnt it always?) corrected it and it works...


Community Member, 203 Posts

9 April 2010 at 1:39am

Edited: 09/04/2010 1:40am

Ok it works by setting the paths to /sapphire /sapphire/parsers and /sapphire/thirdparty in the .htaccss section in the install.php and then running the install (you will probably only run it during install once or twice anyway).

But since this is an open_basedir install I have to tackle the next problem (sigh)