Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

SS 2.4 RC1 - install problem. [Warning] SS_Cache::require_once(Zend/Cache.php)

Go to End

7 Posts   4061 Views


Community Member, 3 Posts

11 April 2010 at 12:00pm

Edited: 11/04/2010 12:04pm


I am trying to install a clean 2.4 RC1 and I get this when running the install script

If you receive a fatal error, refresh this page to continue the installation

* Setting up 'mysite/_config.php'...
* Setting up /var/www/vhosts/
* Setting up '.htaccess' file...
* Setting up /var/www/vhosts/
* Building database schema...
[Warning] SS_Cache::require_once(Zend/Cache.php) [function.SS-Cache-require-once]: failed to open stream: No such file or directory
POST /install.php

Line 194 in /var/www/vhosts/

185 $backend = self::$backends[$backend_name];
187 $basicOptions = array('cache_id_prefix' => $for);
189 if ($cache_lifetime >= 0) $basicOptions['lifetime'] = $cache_lifetime;
190 else $basicOptions['caching'] = false;
192 $frontendOptions = $frontendOptions ? array_merge($basicOptions, $frontendOptions) : $basicOptions;
194 require_once 'Zend/Cache.php';
195 return Zend_Cache::factory($frontend, $backend[0], $frontendOptions, $backend[1]);
196 }
197 }

o SS_Cache::factory
Line 194 of Cache.php
o SS_Cache::factory(aggregate)
Line 36 of Aggregate.php
o Aggregate::cache()
Line 41 of Aggregate.php
o Aggregate::flushCache(Group)
Line 2751 of DataObject.php
o DataObject->flushCache()
Line 1066 of DataObject.php
o DataObject->write()
Line 486 of Group.php
o Group->requireDefaultRecords()
Line 215 of DatabaseAdmin.php
o DatabaseAdmin->doBuild(1)
Line 1012 of install.php
o Installer->install(Array)
Line 190 of install.php

I have no clue what to do.
I hope someone can help.


Attached Files

Community Member, 79 Posts

13 April 2010 at 1:33am

Edited: 13/04/2010 1:52am

I'm getting an error at the some point (though I have PHP error display turned off for the server, so am not seeing the error message) but it gets to the same point and then just stops - the page is truncated after "Building database schema...".

It looks like it has something to do with the search path. There are many places in the code that include Zend library code using this construct:

require_once 'Zend/Foo.php';

Unless the search path is changed at run-time to include the path to Zend, I'm not sure how the include would even work. This instance (the one not working for me) is on a different server from previous working instances, so I wonder if SS was actually calling up Zend library components from the server rather than from its own installation?

-- Jason

Edit: sorry, turns out mine is a different error:

Fatal error: Class 'DOMDocument' not found in /home/example/public_html/silverstripe/sapphire/integration/HTMLValue.php  on line 20


Community Member, 45 Posts

13 April 2010 at 2:24am

In reverse order...

Judge - Your error is because you are missing the php-xml (or -enable-xml compile option if self built) package from your installation.

MooseMan - Check this post - I'm pretty sure that this covers the issue that you are seeing, along with the bug report that has been raised.



Community Member, 79 Posts

13 April 2010 at 3:22am

Edited: 13/04/2010 3:22am

OwenW - Yes, this fixed it:

# yum install php-xml

Installs like a dream now. I wonder if this needs to be a part of the pre-flight checks in the install process?

MooseMan - apologies for the thread hi-jack.

-- JJ


Community Member, 3 Posts

13 April 2010 at 7:19am

Edited: 13/04/2010 7:40am

thanks for you reply.

well, I did see that post ( ) and I didn't think it was the same. Did some more time reading the ticket on trac and it seems that I dont even have the files mentioned
/sapphire/thirdparty/Zend/Cache.php does not exsist...

Now Im trying to re download 2.4.0 RC1 again, and I will try to install on a new subdomain - again... will be back with results.



later same evening...

Installed again, didn't get the error (dont know why).
process halts when trying to redierct me to : /home/successfullyinstalled?flush=1 returns 404.

Hmm - getting tired ;(



Community Member, 45 Posts

13 April 2010 at 11:08am

Hi MooseMan,

The new issue sounds kinda like you have a rewrite issue, or that the initial build has indeed been unsuccessful.

Can you get the the home page wthout the GET var?



Community Member, 3 Posts

15 April 2010 at 7:47am

Edited: 15/04/2010 9:29am

I don't know what that means (GET var). Sorry I really sound like I know nothing at all.
I couldn't get any pages any way I tried.

I'm trying to reinstall RC1 again.


Same problem again


gives 404


OK, now I dont get anything anymore...
third time worked.

now it is up and running