Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Date.Timezone - Will Not Accept Any value


Go to End


2 Posts   673 Views

Avatar
Donb

Community Member, 2 Posts

6 September 2017 at 11:07am

I am trying to install Silverstripe on a existing server and everything works until I get to the validation and it keeps giving the message "date.timezone option in php.ini must be set correctly." I have tried every valid date setting for west coast America including "America/Los_Angeles", "America/Denver" and "America/Vancouver". None of them work. It is very frustrating because I have no Idea what it wants. I have tried it with double quotes, single quotes, no quotes. Every attempt fails. Any ideas on what to do. I am on php5.6.30

Avatar
Donb

Community Member, 2 Posts

7 September 2017 at 2:26am

Some additional info. I found that my WAMP install will accept a date.timezone = "UTC" but my Debian Linux version won't accept it or anything else. I also have another Linux box that has the date.timezone commented out and it accepted the install.