Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Silverstripe 4.0.0 Beta 3, Post install warning


Go to End


2 Posts   1368 Views

Avatar
elruo

Community Member, 4 Posts

22 September 2017 at 1:06am

Hi all!
Today I did a test install of Silverstripe 4.0.0 Beta 3.
Installtion works fine, but afterwarts I get this warning:

[Warning] chmod(): Operation not permitted
GET /
Line 349 in /var/www/silver40.beta3/vendor/league/flysystem/src/Adapter/Local.php

All files and directories of my installation are:
- owned by www-user:www-user
- rights are set to 0664 for files
- rights are set to 0777 for all dirs

This warning comes up on all pages and backend too.

What is wrong here?
Thank yout!

Avatar
elruo

Community Member, 4 Posts

25 September 2017 at 8:26pm

Ok, got it!

System tries to chmod "assets/.htaccess" to 0600.
In fact it is already 0600 but the owner of this (and all other) files of the installation
is owned by a "hosting user" != www-data.
I could fix it as root user...

@developers: please take into account, other installations may not have root rights on their hostings...