Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Fatal error: Call to undefined method HttpRequest::addHeader()

Go to End

3 Posts   2199 Views


Community Member, 19 Posts

4 May 2010 at 10:20pm

Edited: 04/05/2010 10:24pm


i have a strange problem that occured recently. i changed my - i put an hart coded link in and uploaded the file. at first glance everything seems ok, because the link apeared and i did not get any error message. now after two days i visited my page again i get this message:
Fatal error: Call to undefined method HttpRequest::addHeader() in /www/htdocs/xxx/xxx/xxx/sapphire/core/control/Director.php on line 115

i tried this to fix the error:
1.i uploaded "blackcandy" and changed the theme in mysite/_config.php. but it is still the same error in the frontend. (of course with /?flush=1 at the end)
2. .../?flush=1 - still the same error
3. ... /dev/build - still the same error (but i gues this is only possibel if iam loged in)
4. ... i overwrote to the previouse version as it was working - still the same error

what is this? and how can i fix it. i am wondering if it would help to make an upgrade? because i am running 2.3.3 ....
could it be an cache problem? an where?

thank you for any help
g.m. :(


Forum Moderator, 1391 Posts

5 May 2010 at 3:38am

Edited: 05/05/2010 3:45am

You might already have found this thread:

Maybe the problem lies with your provider changing some server settings, and not with your code?

[edit] Also I just remembered something about the HTTPRequest/HTTPResponse classname conflicting with the php HTTP extension your provider may have enabled recently. Here's another link:

Upgrading probably isn't such a bad idea anyway, since we're at 3.7...

Good luck!


Community Member, 19 Posts

5 May 2010 at 4:19am

Edited: 05/05/2010 4:21am

oh! thnks! i think this is it. i have changed my main domain-name and i think this is what is going wrong.
but how can I chage the url, where can find it. i have looked inside main.php and discovered just a lot of variables. maybe this answer lise somewher in the DataBase or in an sapphire .php file?