Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

2.4: CMS will not load properly

Go to End

9 Posts   4063 Views


Community Member, 4 Posts

6 May 2010 at 6:27pm

Edited: 06/05/2010 6:29pm


I don't know if it's a bug or if my machine has lost its marbles...
I did a fresh install of Silverstripe 2.4 on my windows machine (using php 5.2.9 and mysql 5.0.51a) with no extra themes or modules. just a clean install. Language was set to German.
Everything went fine until i first logged in into the CMS. Whenever I switch between pages (like from "Home" to "About"), the CMS won't finish loading the page's content.
If I hit F5 a js-popup appears and asks if I really want to switch pages because I have not saved the changes made on the last one. But since the CMS does not load the pages properly for editing, I could not have edited anything. After the Refresh via F5, everything is loading fine. Until I switch pages again.
I attached a screenshot that shows that the page I navigated to keeps loading (like forever).

Any help is massively appreciated.

P.S.: I did not have those problems with a previous version of Silverstripe.

Attached Files

Community Member, 4 Posts

6 May 2010 at 6:59pm

I reinstalled my PHP/MySQL environment to the latest versions. Problem seems to be gone now. But during the installation process the installation interface said that my old environment met all the requirements...strange.

Never mind :-)


Community Member, 5 Posts

8 May 2010 at 4:27am

Edited: 08/05/2010 4:27am


I've just updated to SilverStripe 2.4.0 and also got the exactly same error.

System is:
"Linux ruby 2.6.28-18-server #60-Ubuntu SMP Fri Mar 12 05:11:07 UTC 2010 x86_64 GNU/Linux"

The PHP/MySQL versions didn't change since the SilverStripe update.

Is there anything else i could try?

Thanks for any help


Community Member, 5 Posts

8 May 2010 at 4:41am


I've tried to debug it and firebug throws an error:

The following requests were sent:


After loading the page:
GET /admin/EditorToolbar/ImageForm?action_callfieldmethod=1&fieldName=FolderImages&ajax=1&methodName=getimages&folderID=&searchText=&cacheKillerDate=1273250077738&cacheKillerRand=4394
Result: 200 OK 840ms
jquery.js (Line 5252)

Clicking another page in the tree:
POST /admin/getitem?ID=27&ajax=1
Result: 200 OK 422ms
prototype.js (Line 765)



$('SwitchView').innerHTML = $('AjaxSwitchView').innerHTML;

/cms/javascript/LeftAndMain_right.js?m=1270613432 (Line 29)


The error is only "$(". I wonder if both javascript frameworks are needed: prototype and jquery ?


Community Member, 5 Posts

8 May 2010 at 4:59am


The fix was easy. Append ?flush=all to your admin url:


as described here:


Community Member, 114 Posts

11 May 2010 at 4:05am

Edited: 11/05/2010 4:06am

same issue, thankfully flush fixed it (but not after a lot of heartache). seeing as this happened on a fresh installation perhaps it is a more major issue? an SS newbie would be super confused (where I was only _really_ confused).


Community Member, 17 Posts

27 May 2010 at 6:51pm

Same issue for me, running Snow Leopard with a fresh install of SS 2.4. Not using MAMP, just standard mac setup. Flush sorted my issue too, cheers for posting the fix.


Community Member, 16 Posts

25 September 2010 at 4:14am

I'm having a problem with the CMS loading as well, but I suspect it is different than yours as flush has not fixed it. My CMS loaded fine for a while and then the other night I tried to log in and could not. I enter the form data and submit and then the CMS load screen sits with the SS logo and does not move past that point. I waited a few days and tried again and the same thing.

I cannot figure this one out. I had edited an ImageDataObjectManager to add more fields, ran dev/build and then tried to log in. Nothing. Any ideas or has anyone seen this before?


Go to Top