Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Include Path Problem

Go to End

21 Posts   8424 Views


Community Member, 2 Posts

15 December 2010 at 7:30am

HI Sean, I have been following this thread with interest as I am also having problems - though my error message is slightly different. I have actually managed to install Silverstripe successfully but am getting error messages when viewing pages which say:

Warning: require_once(core/ManifestBuilder.php) [function.require-once]: failed to open stream: No such file or directory in /usr/local/psa/home/vhosts/ on line 198

..which seems to be the same issue with the include path. The very strange part is that this issue is intermittent! Occasionally the site will work for a few pages but then the error will return. I have implemented the changes to Core.php as described in your ticket with no effect.
The output from your debugging code produces this output:
string(10) "before: .:" string(9) "after: .:"

..which is pretty minimal. But after multiple refreshes it sometimes (when it would be normally working I imagine) it produces this.
string(10) "before: .:" string(235) "after: /usr/local/psa/home/vhosts/"

I have also tried the alternative addition to the .htaccess file mentioned with no success either.

By-the-way the site works fine running on my Mac locally - the issue is when it is running on my shared hosting. Also when contacting my hosting company they thought I was mad to ask them to allow me to set the include path as they see this as a security risk. They said I would then be able to access other people's sites on the shared host and wondered why the paths were not set relatively. I dunno - it's all a bit above my head to be honest!

Anyway, any help would be greatly received. I am way behind my deadline on getting this website up and running and my normally good-natured client is starting to loose his patience!

Many thanks,


Community Member, 60 Posts

15 December 2010 at 9:05am

Just to give you an update on what happened with me. I was unsuccessful in getting the htaccess file to act as a work around. I contacted my clients host and they said they could not allow the include path function to work because of 'security issues' (which I find bizarre). Both my client and I agreed to change hosts and we are back on track.


Community Member, 2 Posts

25 January 2011 at 7:14am

I've finally got my site up and running. It seems the .htaccess file from my Silverstripe install overwrote a configuration for enabling fastCGI. Here quoted from a response to a support call:

"The change i made to the setup for the include paths was done for the phpfcgi installation, but it seems that youre install has actually overwritten the .htaccess that turns this on, please add the following to your .htaccess and then let us know if you have any issues and supply full errors:

RemoveHandler .php
AddType application/php5-fcgi php
Action application/php5-fcgi /cgi-bin/php5fcgi.fcgi"

After that I got some errors due to permissions being wrong on some folders but once that was fixed all was OK.

Christian Hilles

Community Member, 6 Posts

8 June 2011 at 8:53pm

Hi @all,

since yesterday i've the same problem. It is an running system and now it have the problem.

I can't add the include pathes. Not with PHP and not with a .htaccess. All is not pssible from the provider.
The Hosting Company told me that i should replace all relative pathes with absolute pathes.
That needs a lot of time and i must edit so many core files.. Not a good solution!

Is there any other solution for this?
Or is it better to change the provider? :)

Christian Hilles

Community Member, 6 Posts

10 June 2011 at 7:28pm

Hi again,

i've fixed it! It is not a good solution but it works.. I've copied all files of silverstripe include pathes like thirdparty into this folder:

Only the folder "phpinclude" and "." is allowed by this hosting company. Nothing could be changed from anyone.

I can't understand why Silverstripe don't handle this by self.. For example in an config variable. This would be much better for systems on an simple hosting package.

Best regards,

Go to Top