Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Installtion problem -> Warning: require_once(Zend/Log.php)

Go to End

7 Posts   6384 Views


Community Member, 4 Posts

19 May 2010 at 10:23pm

Edited: 19/05/2010 10:23pm

Greetings all,

I've tested the CMS with a friend and I must say I think it looks great. so I decided to install it myself.

But, my first thread/post on this forum is already a question regarding the installation.

I downloaded the CMS and uploaded it to the host. I set all necessary permissions and also created the cache folder.
I started up the install.php and all preliminary steps passed the test.

As soon as I want to install the CMS, though, it crashes and I see the following message:

================ BEGIN ========================

Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Setting up 'mysite/_config.php'...
Setting up /var/www/xxxx/html/mysite/_config.php
Setting up '.htaccess' file...
Setting up /var/www/xxxx/html/.htaccess
Building database schema...

Warning: require_once(Zend/Log.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/xxxx/html/sapphire/dev/Log.php on line 2

Fatal error: require_once() [function.require]: Failed opening required 'Zend/Log.php' (include_path='.') in /var/www/xxxx/html/sapphire/dev/Log.php on line 2

================ END ========================

I had a look and couldn't find any ZEND directory, and obviously couldn't find a log file.

I have searched the forum, but cannot find a solution. Maybe I'm just an idiot and the solution is simple, but I just can't find it. Anyone have any ideas/tips?

Thanks in advance and greetings from Germany,


Forum Moderator, 922 Posts

20 May 2010 at 7:34pm

Edited: 20/05/2010 7:43pm

EDIT: Solution appears to have been solved here:



Community Member, 4 Posts

20 May 2010 at 10:30pm

Hi Sean,

Thanks for the advice.
I've tried installing it on another vserver-machine (but with the same settings and with the same provider) and managed to set it up there. No errors whatsoever. Hmm.

I had seen the Seba's post while looking for an answer, but to be fully honest I didn't quite understand how he/she solved the matter. (probably because I am a bit of a noob ;-))

So do I need to create an entry like this in the httpd.conf file?

<Virtualhost *>

php_admin_value include_path "/var/www/web5/html/sapphire:/var/www/web5/html/sapphire/thirdparty:/var/www/web5/html/sapphire/parsers"



(I had a look here:

I've set up the domain I'm trying to install SilverStripe on as a "customer" on a virtual server where other domains are also in use. (User: web5)
Surely any changes I make in the httpd.conf file would affect all customers?

Or have I misunderstood something?

Sorry for asking so many question,s but I seriously have tried searching for an answer, but have failed to find the answer. I've also searched the German SilverStripe site and posted the same question there.

Thanks again,


Community Member, 4 Posts

20 May 2010 at 10:39pm

PS: The version I installed on the other machine is: 2.3.3

I also just tried installing 2.4.0 on another domain. Same problem :-(


Community Member, 65 Posts

24 May 2010 at 9:54am

Same problem here with 2.4 on Debian (PHP 5.2.6).
SilverStripe 2.3.5 runs on the same server perfectly.


Community Member, 4 Posts

24 May 2010 at 9:32pm

Hmm, I'm also running on a Debian server.

As far as I know this shouldn#t cause any issues as long as all other requirements have been fulfilled, and I have the right PHP and MySQL versions running.

Anyone have an idea what could be causing this problem with oleze and my installations?


Community Member, 65 Posts

25 May 2010 at 7:10am


At first, i'm Andreas and writing using oleze's account.

We got it running now, our solution is to add a path to DOCROOT/sapphire/thirdparty to PHP's include_path. We did this directly within the apache virtualhost config with php_admin_value as we are managing our own servers. Surely this will also be possible within a .htacces file if the respective provider allows to override php.ini values out of a webspace package.

This solution is, as far as we think, only a temporary one and should be fixed by the developers for the next release. As this issue will cause problems for all modules which are located within the "thirdparty" directory, Silverstripe should be aware that thirdparty modules are always located in this directory.

The best solution would be to implement a global include path which is available as a variable within the whole system. This would help all users of thirdparty modules on webspaces which do not allow to set own include path's. Combined with a system wide routine called "load_module( string $module )" for example, it will enable you to have a highly dynamic structure using Silverstripe and several modules.