Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

silverstripe MS- SQL installation problem

Go to End

26 Posts   6731 Views


Community Member, 20 Posts

28 November 2010 at 6:22am

I have set write permissions to IUSR user only but still get the same error messages.

There is an exclamation mark on the web.config file and folder 'mysite' but since the website works on my local machine I thought it worked OK. Could this be a problem?


Forum Moderator, 922 Posts

28 November 2010 at 2:38pm

Edited: 28/11/2010 2:42pm

The crux of the issue is that PHP still can't write to that silverstripe-cache directory, even though you've assigned permissions. I haven't seen this problem on dedicated Windows server setups, but I'm not entirely familiar with shared Windows servers, as things may have been modified in the web server setup to accomodate multiple users.

I think it's time to ask your host why PHP cannot write into that silverstripe-cache directory even though you've set the permissions correctly. You could just forward them the errors PHP is generating with "Permission denied".


Go to Top