Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

installed but no CMS access?

Go to End

5 Posts   1409 Views


Community Member, 63 Posts

20 July 2010 at 12:29pm

Edited: 20/07/2010 12:30pm

This is my first install of SilversStripe on a webserver other than WAMPserver on local host, so I'm still figuring things out ...
I ran install.php and all went well up to the "checking that friendly url's work" part where it came up with:

Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
mod_rewrite is enabled
AllowOverride All is set for your directory

I ran dev/build?flush=all as suggested in another post I found on this forum and that seemed to work, it came up with the default home page with black candy theme, but when i click on the link to open the cms it opens another page exactly the same as the default home page, the url changes to /admin at the end but the cms doesn't open, just opens the home page again.

webhost is

Any help please?


Community Member, 63 Posts

20 July 2010 at 4:26pm

Help please!

I've tried reinstalling several times and can't get it past 'friendly url's not working'
Have tried editting .htaccess several times as per suggestions on various posts around this forum but nothing seems to be working it's still getting stuck at 'friendly url's not working', when i refresh the page to continue installation it just starts over.

I've been trying to figure this out all day and i'm getting nowhere. please help


Forum Moderator, 922 Posts

20 July 2010 at 5:10pm

Edited: 20/07/2010 5:12pm

This is usually because your host hasn't setup "AllowOverride All" and friendly URLs won't work as a direct result.
This can occur even if mod_rewrite has been enabled, but AllowOverride has been set to "None".

You might want to ask your host if you can get "AllowOverride All" setup for your directory where you're installing SilverStripe from. If they can do this for you, SilverStripe should install and operate correctly from then on.


Community Member, 63 Posts

20 July 2010 at 8:00pm

I contacted my webhosts and they said "AllowOveride All doesn't apply to non Apache servers like ours, we have windows servers." and to check the rewrite rules in my .htaccess


Forum Moderator, 922 Posts

21 July 2010 at 9:36am

Edited: 21/07/2010 10:02am

They must be using a third-party tool for rewriting, as .htaccess is specific to Apache. Do you know what they use?

SilverStripe does not officially work with IIS 6, and there has been issues with accessing the admin properly with it using some third-party rewriting tools. There are a few possible workarounds on this forum, e.g.