Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Installing error: Fatal error: Class 'Debug' not found


Go to End


3 Posts   2465 Views

Avatar
monnick

Community Member, 6 Posts

14 November 2010 at 10:31pm

Edited: 14/11/2010 10:32pm

Hi everybody,

Just recently I discovered Silverstripe and I like it very much, it is so simple to configure / design a template! Now I am trying to install a new Silverstripe installation on a new host (from a client), but I get an error...I think it is a problem with the server configuration but I don't know how to fix it. On my own server it works perfectly. Anyway, it says:

Fatal error: Class 'Debug' not found in /var/www/clients/client10/web110/web/sapphire/core/Core.php on line 264

I have tried 2.4.2 and 2.4.3 and both versions give this same error. It occurs directly after I upload all the Silverstripe installation files in to the root folder of the website. I have also tried to chmod every file of the installation, but this doesn't do anything.

Can anyone help me fixing this problem? I don't know what to do anymore...

Avatar
Sean

Forum Moderator, 922 Posts

15 November 2010 at 10:31am

It sounds like there is a missing file... are you sure the files were uploaded correctly?

You may also want to create a silverstripe-cache folder in the project and give it web user write access. Then you can easily delete the temp cache files in there if there's a problem.

Cheers,
Sean

Avatar
monnick

Community Member, 6 Posts

17 November 2010 at 5:01am

Thanks for your reply! Although I double checked it, something was wrong with the file permissions. Now It just works fine :)