Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

silverstripe newbie - admin 404


Go to End


4 Posts   1907 Views

Avatar
gregsaunders

Community Member, 12 Posts

19 November 2010 at 5:49pm

Hello All, I'm a Silverstripe newbie here :) did the install, everything checked out, default site up and running *but* http://localhost/admin comes back 404! What did I miss?

os: linux (ubuntu 10.04)
web server: Apache/2.2.14 (Ubuntu)
silverstripe: 2.4.3
mysql: 5.1

Also, when clicking about the default site after install my urls are coming up

http://localhost/index.php/about-us/

... I'm no apache foo master but this seems like mod_rewrite is not working properly ... but it is enabled

greg@greg-laptop:~$ sudo a2enmod rewrite
Module rewrite already enabled

arg ...

Thanks!
Greg

Avatar
Sean

Forum Moderator, 922 Posts

20 November 2010 at 1:26am

Edited: 20/11/2010 1:29am

I think you are missing the setting of AllowOverride All.

Depending on how you've got Apache setup, the default would be to change it from "None" to "All" in /etc/apache2/sites-available/default (look at the <Directory /var/www/> directive settings).

That might be different if you've setup a virtual host, or are using a different DocumentRoot.

Hope that helps you.

Sean

Avatar
gregsaunders

Community Member, 12 Posts

20 November 2010 at 5:53am

Dude, that worked! Thanks!

Avatar
Sean

Forum Moderator, 922 Posts

20 November 2010 at 11:16am

You're welcome. :-)