Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

You need mod_rewrite to use friendly URLs with SilverStripe, but it is not enabled.

Go to End

2 Posts   2691 Views


Community Member, 1 Post

27 November 2010 at 6:54am


Trying to install latest version. Software looks awsome by the way.

I'm having issues right after the install, I get the following error:

[User Error] Couldn't run query: ALTER TABLE "Page" RENAME "_obsolete_Page" Table 'concep22_voyagesalm.Page' doesn't exist
POST /Projets/ALM2/install.php

I'm hosted at JustHost. I have contacted them andthey told me this : mod_rewrite is enabled by default on all our servers, it looks like there is some problem with script you are trying to install, please make sure that you have uploaded all needed files and contact it's developers.

I'have looked somewhere in the forum and tried to add this in my .htaccess :
<Files *.ss>
Order deny,allow
Deny from all
Allow from

<Files web.config>
Order deny,allow
Deny from all

ErrorDocument 404 /assets/error-404.html
ErrorDocument 500 /assets/error-500.html

<IfModule mod_alias.c>
RedirectMatch 403 /silverstripe-cache(/|$)

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /Projets/ALM2

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L,R]

(the R)

Still not working.

When I go back to the install page, it gives me this still :

Line 526 in /home/concep22/public_html/Projets/ALM2/sapphire/core/model/MySQLDatabase.php

517 }
519 function databaseError($msg, $errorLevel = E_USER_ERROR) {
520 // try to extract and format query
521 if(preg_match('/Couldn\'t run query: ([^\|]*)\|\s*(.*)/', $msg, $matches)) {
522 $formatter = new SQLFormatter();
523 $msg = "Couldn't run query: \n" . $formatter->formatPlain($matches[1]) . "\n\n" . $matches[2];
524 }
526 user_error($msg, $errorLevel);
527 }
529 /**
530 * Return a boolean type-formatted string
531 *
532 * @param array $values Contains a tokenised list of info about this data type

Can someone please help me ?

thanks a lot,



Forum Moderator, 922 Posts

28 November 2010 at 2:45pm

Hi there,

After the installation has failed, have you tried browsing to the site anyway?
You could also try this:

That will attempt to rebuild the database, which by the looks of it seems to be incomplete given the MySQL errors there.