Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Apache problem: Forbidden. AllowOverride?


Go to End


3 Posts   3975 Views

Avatar
monnick

Community Member, 6 Posts

29 November 2010 at 2:34am

Hi all,

I am trying to install Silverstripe 2.4.3 but I get this "Forbidden: You don't have permission to access / on this server." (403) error all the time. I think it is a problem with the Apache configuration on the server. Silverstripe should be installed on a subdomain "dev.domain.com" so I created the file /etc/apache2/sites-available/dev.domain.com which contains the following lines:

<Directory /var/www/dev.domain.com/>
    AllowOverride All
    Options +Indexes
    Order allow,deny
    Allow from all
</Directory>

<VirtualHost *:80>
    ServerName dev.domain.com
    DocumentRoot /var/www/dev.domain.com
</VirtualHost>

<VirtualHost *:443>
    ServerName dev.domain.com
    DocumentRoot /var/www/dev.domain.com

    SSLEngine On
    SSLCertificateFile /etc/apache2/ssl/www.domain.com.crt
    SSLCertificateKeyFile /etc/apache2/ssl/www.domain.com.key
    SSLCertificateChainFile /etc/apache2/ssl/www.domain.com.ca-bundle
</VirtualHost>

Of course I have enabled the site by using:

sudo a2ensite dev.domain.com

And afterwards restarted Apache with

sudo /etc/init.d/apache2 restart

Now when I surf to the subdomain I get the following 403 error:

Forbidden

You don't have permission to access / on this server.

I have tried all kinds of things but I can't get it to work. One of the things I have tried is to edit httpd.conf and apache2.conf and set AllowOverride to All...doesn't make difference...

Does anyone know how to solve this problem? I am kind of desperate right now...

(The whole subdomain directory is chmodded to 755 and is owned by the user/group www-data)

Avatar
bartvanirsel

Community Member, 96 Posts

29 November 2010 at 6:13am

Hi,

What's in your .htaccess file?

Avatar
Sean

Forum Moderator, 922 Posts

29 November 2010 at 12:57pm

Still sounds like a file owner issue. Are you sure some of the files are owned by the webserver user?

Also does the .htaccess file have a RewriteBase line?

Sean